2
$\begingroup$

It is the first time I'm trying to make fur in Cycles, I'm far from being an expert so I followed Blender Guru's tutorial for that and it looks the way I want it in the preview. But once I tried rendering, the fur looks way more long:

previews

I have already tried to turn down all the sizes, to zero even, but nothing changes, it still looks super long when I try to render.

I'm also using subdivision surface on the meshes.

Like I said, this is my first time trying hair/fur and my blender knowledge is very limited so I'm sorry if this is a beginner mistake but any help would be very appreciated!

Thanks in advance.

EDIT: here's the blend file!

$\endgroup$
  • $\begingroup$ Hmmm, hair has so many settings $\endgroup$ – 10 Replies Jan 10 '17 at 23:13
1
$\begingroup$

I got it.

Just when I set Particles>>Render>>Degrees:7 and B-spline>>Steps:7.

I think it has relations with Particles>>Display>>Color also set to 7.

The picture below:

enter image description here

$\endgroup$
0
$\begingroup$

I can't see anything wrong with your hair settings, so the problem is likely to be elsewhere.

Check each modifier above the hair particle modifier and make sure their viewport settings are the same as their render settings. This means they should all be visible in the viewport and if there are any settings that are render specific (e.g. subdivision count) that they match viewport. In particular ones that add or remove geometry can break the hair cache and cause odd results.

If you want to alter subdivision between display and render, you need to either move it below the hair modifier or split it in two and have one before the hair with display and render settings equal, and one after with only the additional render subdivisions.

Round 2:

After playing with the blend far a while I can't find anything obvious, I slowly turned off / reset to default all the settings in the hair particle system and eventually managed to make the system render more or less the same as the viewport, however resetting just the last setting changed (brownian in the physics tab) did not fix the original group. From this it looks like the problem is some strange interaction of settings in the group.

My recommendation would be to recreate the hair systems from scratch, doing quick renders after each change until you get something satisfactory. Hopefully someone else can come along and give a better answer though.

$\endgroup$
  • $\begingroup$ thank you for the reply! I did check if the modifiers were visible on both preview and render! And the Subdivision settings also are the same for both. Idk if it's possible (I'm new here) but I could upload a blend file if it'd help more. $\endgroup$ – Jay Jan 10 '17 at 3:46
  • $\begingroup$ @Jay a blend file would be helpful, the preferred host here is blend-exchange.giantcowfilms.com $\endgroup$ – Sazerac Jan 10 '17 at 5:28
  • $\begingroup$ @Jay I've updated my answer with what I could find. Not much unfortunately. $\endgroup$ – Sazerac Jan 11 '17 at 12:04
  • $\begingroup$ I really appreciate the help!! I was afraid that starting over would be the best solution but I'll try that. Thanks again!! $\endgroup$ – Jay Jan 11 '17 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.