Sometimes when handling scenes from other users I get a render that doesn't show until it's completely done.

It's probably just a setting that's ticked on or off but I can't figure out where to find this or even what it's called nor what the purpose of this is.

Operating system: Windows 7 professional
Blender version: 2.78
Render engine: Cycles
Occurs both on CPU and GPU (msi GEFORCE GTX 980Ti) rendering

Some in depth explanation on this matter would be greatly appreciated! (advantages/disadvantages/...)

EDIT: (included a screenshot that shows the settings I'm using.) enter image description here

  • @cegaton Done! GEFORCE GTX 980Ti – Delagone Jan 9 '17 at 16:48
  • This doesn't really look intentional, more looks like a bug, although I can't be sure, when it's done, I presume it gives you an image? – Luka ash Jan 9 '17 at 18:00
  • It is possible you accidentaly changed the slot before you started the render? – Alphisto Jan 9 '17 at 19:07
  • I have the exact same issue in one of my computers running windows 7, blender 2.78, and 2xGTX780Ti: It renders fine, but it does not update the screen as it renders, only when it is finished. – cegaton Jan 9 '17 at 19:09
  • 1
    @Delagone did you ever resolve this? – cegaton Jul 19 '17 at 18:14

It might be that you're accidentally previewing a RenderLayer which is currently not being rendered, or a pass which does not exist within the current render layer. I had situations like this in the past at least.

While the render is running, check in the bottom of the image editor and verify if the current render layer which is calculating is really set to be previewed. In the following screenshot, I've kicked off a rendering, which starts rendering Layer A. But before that, I had set the preview slot to display Layer B. For some reason, Blender does not switch back to Layer A when the render fires off, see the bottom section of this screenshot:

empty preview

Switching to Layer A while the render is running solves the issue for me.

  • Thanks for the help, Yet I'm using only 1 renderlayer. I've included a better screenshot which shows the settings I've used. – Delagone Jan 10 '17 at 8:17
  • @Delagone Very odd. Is it possible for you to share the file? You could even remove the models contained and just drop in a cube for testing. – aliasguru Jan 10 '17 at 10:10
  • I'd like to provide you something for testing but due to a strict NDA I really can't. hope you understand – Delagone Jan 10 '17 at 10:35
  • @Delagone sure, no problem. – aliasguru Jan 10 '17 at 11:27

Try to turn off "Save Buffers" in Properties -> Render -> Performance. It helped me in Blender v2.79

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.