2
$\begingroup$

I've been a user of Blender for a very long time (not that I'm skilled though XD ) and while I normally use Cycles or LuxRender, I gave Renderman a try.

I was able to install it successfully, even installing the Maya Renderman even though I don't have Maya, just to get 'it'. But there's a problem.

I modeled a really simple scene: model

And while rendering it using Blender's internal framebuffer works, blender

rendering it with 'it' fails for some reason, and just shows 'it', doing nothing, "Empty" written in its title bar. it

Nothing happens no matter how long I wait, Blender becomes non-functional from here on because cancelling the render just takes forever, and I have to force close Blender from the task manager and restart Blender just to take another try.

My Blender version is 2.78a, my Renderman is 21.2, and since I can somehow render images, just not with 'it', I'm sure I installed Renderman and the Blender plugin correctly, but what could be wrong?

Thank you in advance for your support.

$\endgroup$
  • $\begingroup$ Does renderman has it's very own camera system, like vray? $\endgroup$ – hawkenfox Jan 9 '17 at 14:42
  • $\begingroup$ It works for me... Did you restart the computer after installing Renderman? (I remember that I had issues until I restarted). $\endgroup$ – lbalazscs Jan 9 '17 at 15:22
  • $\begingroup$ Restarted but to no avail. However, surprisingly enough, setting "Render to" to 'it' and clicking "Start IPR" instead of "Render" works. I don't know if there is any difference between the two (yes, I know what IPR means, but I don't know if I can render my final work with IPR) $\endgroup$ – Kyle Alexander Buan Jan 9 '17 at 23:50
  • $\begingroup$ Does it work when you turn off denoise? $\endgroup$ – bsavery Jan 13 '17 at 23:34
0
$\begingroup$

I have been using RM for a month or so now.

Make sure your IPR is running before you render. Using your viewport is almost pointless for viewing your renders.

Everything is run through "IT".

Make sure you have Blender rendering to "IT" enter image description here

If you want to upload your blend file I can test it out.

I would recommend going through the RM forums

https://renderman.pixar.com/forum/forumdisplay.php?s=&forumid=166

They are awesome, they usually respond very fast for any problems.

PS Not sure what you meant by installing the MAYA version to get "IT". That might be the problem. I didnt do it that way. "IT" should just come with RM. I did NOT install the MAYA version, I still have "IT".

$\endgroup$
0
$\begingroup$

For whatever reason, "Render to it" doesn't work for me either. I use the External Rendering. This spools your job to the LocalQueue (or Tractor) application which will render it in it.

To render externally, open the "External Rendering" panel under the render settings. Check "Enable External Rendering". Make sure you are set to render to it (default) and to spool to LocalQueue (default). If you are rendering an animation, check "Render Animation". Now, when you need to render, press "External Render" instead of "Render".

enter image description here

If it isn't already open, LocalQueue will launch. You can manage your render jobs from this window.Your scene will render whatever is currently in Blender at the time you called the render. It will not autoupdate. If you want to cancel a render, then select it in LocalQueue and delete it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.