0
$\begingroup$

I am trying to use inverse kinematics but for the bone would not bend in the right direction so i tried rolling it but the it deformed the foot and leg of the mesh how do i fix this?

enter image description here

enter image description here

$\endgroup$
5
  • $\begingroup$ Please upload your .blend file to be able to help you $\endgroup$
    – Tak
    Commented Jan 9, 2017 at 4:10
  • $\begingroup$ how do i do that? $\endgroup$
    – A guest
    Commented Jan 9, 2017 at 5:51
  • $\begingroup$ Use this link blend-exchange.giantcowfilms.com $\endgroup$
    – Tak
    Commented Jan 9, 2017 at 5:54
  • $\begingroup$ I have uploaded the file $\endgroup$
    – A guest
    Commented Jan 9, 2017 at 5:57
  • $\begingroup$ I've provided an answer to your problem with steps and an updated blend file. You can accept the answer and upvote the answer if it solved your problem :) $\endgroup$
    – Tak
    Commented Jan 9, 2017 at 8:17

1 Answer 1

1
$\begingroup$

There are couple of problems in your file.

First the IK bones needs to have the deform property disabled as shown below:

enter image description here

Second, you need to adjust the pose position to be your rest pose to avoid bad bone roll values. To do this, switch to pose mode select the whole armature bones by pressing A then hit the space bar and write Apply Pose as Rest Pose as shown below:

enter image description here

Last thing is parenting your mesh to your armature. To do this, go to object mode, select your mesh first, then select your armature with right-click, then hit ctrl+P and choose With Automatic Weight and that's it, the mesh will be nicely deformed and parented to the armature as shown below:

enter image description here

The updated .blend file can be found here:

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .