6
$\begingroup$

When I create a UV sphere and add the subdivision surface modifier, the following wrinkle appears.

enter image description here

How can I avoid it?

I've read the article How to handle distortion at the poles of a UV sphere? but there seems to be no clear solution.

UPDATE 1

I've used the word 'apply' in the first sentence of the initial version of this question. It's misleading since I want to preserve the modifier without 'applying' it. Rather, what I meant is 'adding' the modifier.

UPDATE 2

I followed josh sanfelici's solution, but still there is an artifact at the pole.

Here is the screen: (A rendered view with a sun lamp)

enter image description here

Maybe it's the limitation of the general-purpose subdivision modifier.

BTW, when the cast modifier is added after the subdivision modifier, the sphere becomes perfect (even for my original wrinkled sphere). But since I want to edit the resulting sphere (for example, scaling X, Y, etc) while modifier is added but not applied, it's not usable.

$\endgroup$
10
$\begingroup$

The wrinkles are generated by the triangles that connect the pole to the rest of the mesh. Even quads with one side much longer than the other can lead to similar problems, expecially with subsurf. My favourite way of get rid of it is to delete the pole vertex, loop select the circle, extrude and scale down until near of the center, then Ctrl+F Grid Fill. Then select the new central pole, activate the proportional editing with sphere falloff and grab the pole to the old position, that can be "marked" with the 3D cursor (Shift+S cursor to selected). Then you can expand your selection with Ctrl++ and use the "smooth vertex" function in the toolshelf T. enter image description here

You'll have to do some experiments: if the last circle is near the pole you'll have artifacts, if it's very distant you'll have to set the sphere "by hand", also the smooth vertex function requires some manual adjust. If you need perfect sphere use icosphere instead.

enter image description here

$\endgroup$
  • $\begingroup$ Please see my update on the question. $\endgroup$ – zeodtr Jan 9 '17 at 14:52
  • $\begingroup$ Updated the answer. $\endgroup$ – josh sanfelici Jan 9 '17 at 19:14
  • $\begingroup$ Thanks. But by seeing your answer, I feel that there is no 'clear' solution. $\endgroup$ – zeodtr Jan 15 '17 at 6:14
9
$\begingroup$

You could use a Cast modifier on a quad sphere, if you want to do something like Paul Gonet's answer, but non-destructively:

enter image description here

In addition, if you want to map a texture onto this sphere, you can use the Sphere projection on the image texture node. This avoids all the issues that occur at the poles of UV-mapped spheres:

enter image description here

$\endgroup$
4
$\begingroup$

As an alternative to @josh sanfelici 's answer you can add a cube, add a subsurf modifier to it (with some subdivisions) and apply it. Then you may use a To Sphere tool (Alt+Shift+S) and set its value to 1.000 using the keyboard. It'll make the mesh a perfect sphere. enter image description here

$\endgroup$
1
$\begingroup$

You can also get a normal UV sphere and just go to edit mode. Then press W to bring the specials menu and click Subdivide Smooth. Now, if you go back into object mode there will not be any wrinkles.

$\endgroup$
  • $\begingroup$ This is fascinating, what is the difference between the subdivision surface modifier and the subdivide smooth option? Is there a modifier like the subdivide smooth option? $\endgroup$ – Leander Sep 13 '18 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.