0
$\begingroup$

I'm having this problem

If you notice que is this weird shading on the curve , how can I fix it? i dont really know what it is, I've already tried flipping the normals but nothing, what else can i try? thanks! P.S. the mesh was imported from unreal, because in unreal it shows this problem enter image description here

$\endgroup$
  • $\begingroup$ did you try recalculating normals by going into edit mode, selecting the entire mesh, and then pressing ctrl + N? $\endgroup$ – 10 Replies Jan 7 '17 at 0:11
  • $\begingroup$ yes! i also tried manyallu flipping one by one but nothing its still the same issue just the darkes area inverts $\endgroup$ – Lohug Jan 7 '17 at 0:15
  • $\begingroup$ did you try removing doubles? $\endgroup$ – 10 Replies Jan 7 '17 at 0:16
  • $\begingroup$ yes actually i did't before exporting it to unreal $\endgroup$ – Lohug Jan 7 '17 at 0:36
  • 2
    $\begingroup$ This looks like iimported custom split normals wrongly shading the mesh, see blender.stackexchange.com/questions/35185/…. $\endgroup$ – Mr Zak Feb 12 '17 at 9:58
0
$\begingroup$

Fixed it, if you are importing from blender to unreal, and get the degenerate tangent base problem ujst uncheck this enter image description here

the first two options P.S. sorry, my unreal engine is in spanish

$\endgroup$
  • $\begingroup$ sorry for the extremely late selection, didnt notice this open thread i got overflowed with work, sorry man but yeah, this was exactly the same i did to fix my issue! $\endgroup$ – Lohug Oct 11 '17 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.