0
$\begingroup$

In the compositing layout the alpha over won't work. The background stays grey. How to make it transparent so that the background can be seen?

I followed this tutorial here: https://www.youtube.com/watch?v=l26kp1ETRk8

img

I wouldn't mind rendering just the image, and I did, but the strip alpha overlay doesn't work either, because it's a grey colour.

$\endgroup$
  • $\begingroup$ Please, don't plug the alpha channel into the Fac. The fac should be used to set the strength and is usually set to 1. If your image has alpha (which is the case), you can just unplug it. Otherwise, use the Set Alpha node to set the alpha. It basically does the same, but is kind of bad style. $\endgroup$ – piegames Jan 6 '17 at 15:06
  • $\begingroup$ The issue is that your original render layer has no alpha channel. $\endgroup$ – user1853 Jan 6 '17 at 16:14
2
$\begingroup$

Go to the render tab -> Shading and change the Alpha from Sky to Transparent.

enter image description here

$\endgroup$
0
$\begingroup$

You need to set make the background transparent by setting it to Holdout in the world settings. Then you need to enable transparent rendering as shown in this answer. Short version: In the Render panel, set output type to RGBA and enable Transparent in Film.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.