0
$\begingroup$

Google shows that Blender's slow rendering has been questioned numerous number of times before too, but in my case it has gone to a degree that rendering even the simplest things requires ages. I'm using latest 2.78a version on Windows 10.

I understand that my machine is a humble one by any stretch (i5 + 8GB + Samsung 850 Pro SSD), but my expectation was that simple scenes involving a few cubes, one light source, one camera and a handful of materials would render in about a couple of minutes or less. Instead it takes the likes of 15 to 20 minutes every time I press F12 (blender says the scene has 1 lamp, 5 objects, 63 faces and 72 vertices, which I believe is pretty simple).

I have tried the following already. Doesn't make a considerable difference in rendering time:

  1. Changing from CPU to OpenCL: throws error when loading libraries.
  2. Changing Sampling: From 128/32 to 12/6.
  3. Changing Light Bounces: From 12 to 4.
  4. Changing Tile Size: From 64 to 256.

My gut feeling is that this has something to do with Windows 10, but I don't have Windows 7 or XP right now to test if that is the case. Has anyone else experienced this? Any other solutions to make it faster?

$\endgroup$
3
  • $\begingroup$ What are your specs? Also, this may help $\endgroup$ Jan 6, 2017 at 12:40
  • 1
    $\begingroup$ One solution is to boot a linux livecd to use blender. In my case cycles on linux renders just shy of 40% faster $\endgroup$
    – qwazix
    Jan 6, 2017 at 16:58
  • $\begingroup$ lol you don't know what slow is until you try to cycle render on a laptop with a AMD Turion 2 m500 CPU. 40+ seconds to render in cycle. The more cores your CPU has, the better. I recommend a 8 core CPU. $\endgroup$
    – Aaron Odom
    Jan 2, 2018 at 0:22

3 Answers 3

2
$\begingroup$

Make sure you dont have "Square Samples" checked.

enter image description here

$\endgroup$
1
$\begingroup$

If you are using CPU don't make large tile sizes. Experiment a little for your device specifically, but unless you have a good GPU, large tile sizes will just make blender run slower.

It could just be that your computer is slow, but, I have an i5 and I can render things at decent speeds. (Maybe try rebooting and closing all other applications. You could have bloatware open or something)

The real thing that affects render time is how many samples you use. Changing that to be smaller will allow you to get faster lower quality renders.

$\endgroup$
0
$\begingroup$

One thing that really helps if you're doing very simple bakes (e.g. diffuse/color only) - such as you would do for combining or splitting diffuse maps, is to drop the render passes under Sampling to 1.

It's probably NOT a great idea if you're doing anything where the bake truly relies on engine rendering functionality (light map bakes, AO, transmission, subsurface, etc.), but for the simple types of bakes I often do when creating a new model or working on UV maps, setting the output size and tile size to the bake size and dropping rays to 1 seems to work great, and it drops the bake time down to seconds even for 8k maps.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .