4
$\begingroup$

So, I set a .mov file as the image texture of some shapes and when I try and scroll through the timeline, the preview/render just stays as a single image. It should be changing accordingly, right?

I've been trying for hours figuring out and searching for answers—I think I did everything right setting the thing up, but surely something somewhere has gone wrong.

Here is a screenshot of the different views I have:

enter image description here

Thank you for your help!

$\endgroup$
  • $\begingroup$ It looks like you've already done this, but for it to update (at least in textured mode) the object needs to be selected. $\endgroup$ – Anson Savage Jan 3 '17 at 23:45
  • 2
    $\begingroup$ There is nothing wrong with your setup, it just not well supported to update animated textures under the viewport at the moment. Textures will update correctly once you render. $\endgroup$ – Duarte Farrajota Ramos Jan 4 '17 at 1:37
4
$\begingroup$

Well, you should enable auto-refresh in the image texture node so the image is refreshed every frame. Other than that I have made the experience before that I additionally had to set the frame range, start frame, etc. in the image editor for the corresponding texture. enter image description here

$\endgroup$
  • $\begingroup$ Okay, so I tried your suggestions (I did them right, right?) and it doesn't seem to be working! Whenever I scrub through the timeline, the whole video doesn't play, only maybe a few frames at the start but it doesn't reach the end. Here's a new screenshot of the changes that I did! link $\endgroup$ – JP del Mundo Jan 4 '17 at 1:13
  • $\begingroup$ Ooh also! How about the nodes? Do the nodes look alright or do they also affect my problem? $\endgroup$ – JP del Mundo Jan 4 '17 at 1:23
  • $\begingroup$ It looks like you did it exactly right. It could be file related. Maybe your video file is somehow corrupt. I think in any case it would help if you used an images sequence instead of a .mov file though. Try converting it and set it up the same way you did before with the converted sequence. $\endgroup$ – adegner Jan 4 '17 at 4:53
  • $\begingroup$ My video file is alright and plays fine, also converted it to different file formats but ultimately, using an image sequence instead of a movie file did the trick for me!!! Thank you very much for your help. $\endgroup$ – JP del Mundo Jan 6 '17 at 21:29
2
$\begingroup$

To update the image in the viewport, the only solution I've found is to have a window open with the UV/Image Editor (this has to remain open the whole time), select your movie texture, press 'n' (or use the little plus sign at the right of the window) to get some more options. Once there, you need to update the frame count according to your material node, and also check "Auto-Refresh". Once you do that, do not close the UV/Image Editor, and you can now scrub the timeline and it should update your movie in the viewport.

Hope this made sense. I guess blender treats the images differently between the viewport and the actual render.

I doubt you still need this solution, but for future reference I wanted to post this.

$\endgroup$
0
$\begingroup$

In version 2.78 I found that clicking 'match movie length' resolved the issue.

*I was running a background image-movie ( you can see in the left panel ) as well as a texture image-movie on a flat surface. If you only have a texture image-movie, then I would try matching just it.

Matching the movie length for the texture allowed the texture to cycle.

$\endgroup$
  • $\begingroup$ This answer is describing a setting for the internal renderer, the question is referring to cycles though. $\endgroup$ – Martin R. May 26 '18 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.