5
$\begingroup$

I want to make sure vertices of an entire edge loop have the same x position.

I've selected the vertices, set pivot center to individual origins and typed 0 in the x position transform in properties.

They don't move to 0. enter image description here

What am I missing here?

Thank you.

$\endgroup$
  • $\begingroup$ This doesn't work as expected because you're moving the "median" of all selected vertices, and not the individual x values $\endgroup$ – sonofrage Jul 18 at 8:04
6
$\begingroup$

After selecting the loop that you want to position, you can drag your mouse over the X value in the properties menu (it shows up when you press the N key)

enter image description here

If you have vertices that are offset from the center but their average X value is zero (as shown):

enter image description here

You can use the following keystrokes to set the x position of each vertex to zero :

S+X+0

enter image description here

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ imgur.com/a/cNQN9 Sorry cannot figure out how to include an image. This link shows two selected verts slightly offset from the center line - the x position in properties says 0 after I type it but they are NOT at zero. I'm used to Maya where you can type in the channel box with multiple verts selected and all will be moved. Is this possible in Blender? $\endgroup$ – lawrencehagman Jan 3 '17 at 2:32
  • $\begingroup$ @lawrencehagman Okay, I think that is showing the average x position. To align them so that they both have a value of x=0, select both of the vertices, hit s to scale, then x to constrain on the x axis, then 0 to bring them to the median point. I think that's what you're looking for: x>s>0. $\endgroup$ – Anson Savage Jan 3 '17 at 2:53
  • 1
    $\begingroup$ If you want to position them on X=0 on the world coordinates, use Global instead of Local for the transformation. $\endgroup$ – user1853 Jan 3 '17 at 3:14
  • $\begingroup$ Hi, I'm using global and it's still giving me the average position. When click on the pivot center pulldown it says "Bounding Box", I select "Individual Elements". The results are the same. $\endgroup$ – lawrencehagman Jan 4 '17 at 18:56
  • 3
    $\begingroup$ Thank you. S+X+0 works but I'm trying to understand why the properties transform input fields try to average the positions of what is selected. There must be a setting somewhere that I'm missing. I've tried global and local, I've changed pivot points. Huh. $\endgroup$ – lawrencehagman Jan 4 '17 at 21:06
1
$\begingroup$

Surprisingly, what you want to achieve is not directly supported in the UI. However, there are at least three workarounds.

As starting point, lets assume that we are in mesh edit mode (select the object and press tab to enter edit mode), and we have a reference point somewhere in the mesh, which already has the correct coordinate value (the question is regarding X coordinate, but it could be any).

  • Copy-paste numeric value for each point individually: select the reference value, ctrl-C from the coordinate in the Properties panel (press N to show that panel). Then select each point individually and paste in the coordinate value.

  • Use snap-to-vertex for each point individually. Activate the snapping mode, then select one vertex, press "g" (grab) followed by the coordinate constraint ("x" for x coord etc). Then drag with the mouse close to the reference point.

  • Scaling-Trick: use the reference point as pivot, then scale all other points to zero relative to the pivot, and use the appropriate coordinate constraint. In practice:

    • either use the 3D cursor as pivot: then select the reference point, snap the cursor to active (shift-s o). Then select all the other points, and press "s" (scale) "x" (the coordinate constraint) and then enter the numeric Zero.

    • or alternatively use the active point as pivot: thus select all points, and then select the reference point as last one (which is the active point, showed as white marker). Then press again "s" "x" "0"

Further hint: frequently the reference geometry or point exists already within another mesh. You can duplicate it from there, separate it and join it into the mesh you are currently working on. When done with your adjustments, you can Mesh > Clean-up > delete loose

| improve this answer | |
$\endgroup$
0
$\begingroup$

As far as I can tell, there is no way to set positions. Not talking about set transform amounts or medians here, but setting the position of a point or multiple points. In lightwave, for example, there was a "set value" numerical. It was great for precision modeling. After going through a number of forums, I can't find anything of this sort in blender. It would make a great little add on though.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Welcome to bse. When you have sufficient rep, you can comment on posts IMO this should be a comment. $\endgroup$ – batFINGER Aug 5 '18 at 16:15
-1
$\begingroup$

This is easy. Just do as above to get them alligned S X 0 or S Y 0 etc. To get the all to a specific place just hit tab go into edit mode. Select the vertices or edges you want. Press N to bring up Transform menu. Change the Median from Local to Global and type in your position in x, y or z

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Mike, how does this differ from the other answer/? $\endgroup$ – batFINGER Jul 17 '18 at 12:06
  • $\begingroup$ My apologies I did not see cegatons answer. Although I was just adding clarity. $\endgroup$ – Mixstah Jul 18 '18 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.