0
$\begingroup$

I just was working on rigging a model I downloaded online. However, when I bound the rigging to the mesh, for whatever reason, moving the leg also moves a part of the armor on the corresponding arm. It's really weird and I have no idea how to fix it. Please help.

$\endgroup$
  • 1
    $\begingroup$ Could you upload the .blend file to be able to help you? $\endgroup$ – Tak Jan 2 '17 at 22:54
1
$\begingroup$

Ah, this a common issue with automatic weights. It is easily fixable though. Select the armor piece that is moving when it shouldn't be, and enter edit mode. In the properties panel, you should see the Object Data button, which appears as a triangle. In this tab you will see the Vertex Groups menu.

enter image description here

In this menu, select the leg bone in the list that affects the arm to move. Select all the armor mesh in the 3D viewport, then drag the Weight slider all the way down to 0.000. Then click assign. This takes the selected mesh, and sets how much it should move when the leg bone moves (which is now no movement).

Now when the leg bone is moved, the armor piece should not. Repeat this for all occurrences. This should also note that when moved to 1.000 it will move the mesh entirely (and anything in between will move accordingly with the weight value).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.