9
$\begingroup$

When adding a new object, I would like it to come in at a smaller size (scale). I have changed my scene units to Inches and a new mesh object is 2 ft x 2 ft, or 24 inches x 24 inches. It would be convenient to control the size of all new objects to something more manageable like 2 inch x 2 inch.

$\endgroup$

1 Answer 1

11
$\begingroup$

You can achieve stuff like this by setting a custom scale value to the grid itself. I'm working in metric system on my machine and have my scale value set to 0.1, which results in the cube being added having a length of 20 centimeters instead of 2 meters. For imperial, you can set it up like this:

  1. set your units to Imperial in the Scene tab. This sets your main units to feet.

imperial units

  1. Calculate a working scale factor for converting feet to inches, and enter it in the N Panel in the 3D Viewport

scale factor

If I am not mistaken, feet and inches have a relation of 1:12. So the multiplier will be 0.08333333

  1. Save your Startup File using Ctrl + U
  2. Restart Blender, as this only takes effect after doing so

Test it by adding a new cube. It should be exactly 2 inches wide. Note that the grid lines now are also 1 inch apart each.

$\endgroup$
4
  • $\begingroup$ I am using Blender 2.78, and I had taken each of the steps that you suggested, and this is what prompted me to ask the question. I do not in fact get a 2"x2"x2" cube, plane, or any other mesh object. They come in at the same size as though my scene scale were the same default that is shipped with Blender. I did in fact close and restart Blender after saving the user preferences. $\endgroup$ Jan 3, 2017 at 3:18
  • $\begingroup$ Oops... I missed the step of changing the grid display scale in the "N" window. All is working now. Thanks! $\endgroup$ Jan 3, 2017 at 3:25
  • $\begingroup$ @EthosErlanger Great! If this answers your question, please also mark it as 'answered'. $\endgroup$
    – aliasguru
    Jan 3, 2017 at 7:32
  • 1
    $\begingroup$ +1. This still works with v2.80. Only the settings under (2.) are not in the N panel any more, but instead found in the viewport overlay menu. $\endgroup$
    – bogl
    Nov 9, 2019 at 21:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .