3
$\begingroup$

I know this is slightly larger scope than just Blender, but I know other Blender users have had this same problem. I've started using Sheep It and I really enjoy it. When I try getting points rendering on my own computer (and I have to use the .jar file because I use Linux Mint) the terminal outputs:

GPU::generate failed to load CUDA lib (path: cuda)

It still allows me to use my CPU but I could render at least twice as fast if it would recognize my GPU. I've done a little research on this and the only other guy who had this problem I could find was here: https://plus.google.com/112229882551127022642/posts/KL4QtHWHx92

And after some confusing discussion that I don't understand, Sheep It said:

The common thing between the not working system is the driver version. If you are on 331 it does work, if you are on 340 it doesn't. I have no idea why but it least I know what to look for.

So, my Driver Manager looks like this: enter image description here

What are the implications of switching between drivers? If I wanted to, how could I also install nvidia-331? What does all the confusing stuff on that Google+ post mean and would that fix my problem? Most importantly, is there any way to get my current machine, without changing my drivers, to render for Sheep It on my GPU?

UPDATE: I tried all the Drivers in the Driver Manager and none of them fixed the problem. Also, running the jar command as root does not fix the problem either.

Thanks.

$\endgroup$
  • 1
    $\begingroup$ dunno how you can install 331, but if you switch to a different driver, you can definitely switch back to the previous one. No worries on that. Question : do you have the CUDA option in Blender itself ? $\endgroup$ – ChameleonScales Dec 31 '16 at 4:37
  • $\begingroup$ @ChameleonScales So, up until recently, I had to run Blender as root to have the CUDA option, but with the latest graphics card update, I don't have to anymore. One time, something weird happened and I didn't have the CUDA option, but restarting my computer fixed that. $\endgroup$ – Anson Savage Dec 31 '16 at 4:41
  • $\begingroup$ if you can on Blender and not on Sheep it, then I don't have enough knowledge to help you solve that. Sorry. $\endgroup$ – ChameleonScales Dec 31 '16 at 4:56
0
$\begingroup$

The easy(ish) answer is that Cuda isn't actually installed by default on every platform. Blender actually compiles in CUDA libs statically AFIK, but in other programs you will need to install the CUDA toolkit.

https://community.linuxmint.com/software/view/nvidia-cuda-toolkit

Additionally, you can actually install the version from the NVidia site, but it's a bit more compilcated:

https://www.reddit.com/r/deepdream/comments/3cd1yf/howto_install_on_ubuntulinux_mint_including_cuda/

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thanks for the answer. I'm working on it right now. When I install if from there, it says I can't install it: "Can not install 'nvidia-cuda-toolkit' (E:Unable to correct problems, you have held broken packages.) I'll continue working on it, if you know what that's about, that would be great! $\endgroup$ – Anson Savage Jan 4 '17 at 15:12
  • $\begingroup$ Okay, I installed the toolkit, restarted, and it still didn't work. Thanks for the effort though! $\endgroup$ – Anson Savage Jan 4 '17 at 17:12
  • $\begingroup$ I think the NVidia toolkit is probably necessary, but it isn't what fixed the problem. Thank you! $\endgroup$ – Anson Savage Jan 6 '17 at 19:31
0
$\begingroup$

Okay, I figured out the problem. I had to expand my terminal command from the simple jar file:

enter image description here

The first command tells me all the options and the second command allows me to render with my GPU.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.