1
$\begingroup$

I was following the camp fire tutorial on the blender guru YT channel, and i've run into a problem when I try to render my scene. In the tutorial, it says to switch from GPU to CPU for rendering. I can't even see that option in rendering tab though. The fire works just fine otherwise, and i followed the tutorial exactly. Any ideas why the rendering won't work? Thanks in advance!

$\endgroup$
3
  • $\begingroup$ GPU support for smoke/fire has been added since that tutorial was made (at least for CUDA/nvidia). Aside from that, I'm not sure I understand what exactly isn't working? $\endgroup$
    – gandalf3
    Dec 30, 2016 at 10:30
  • $\begingroup$ The problem is that the fire is showing up when I view my scene in solid or material mode etc, but not in an actual render. If I try to render it, it just shows me a black circle where my emitter is. $\endgroup$
    – Toester
    Dec 30, 2016 at 13:24
  • $\begingroup$ I don't know this work for you or not, but works for me. Just name the attribute node "flame" and everything renders fine! Regards, Addy $\endgroup$
    – esculptor
    Feb 23, 2017 at 14:22

1 Answer 1

1
$\begingroup$

That tutorial, as you can see here, is for 2.73, and since then the Blender UI changed a bit, you can find that option in "file=>user preferences=>system" now (it's called "compute device").

You could also download an old 2.73 from the Blender website, to make it easier to follow the tutorial.

Anyway, remember:

  • be sure to use "cycles" render before creating the "quick smoke" setup.
  • save the file in order to enable the cache settings
  • before rendering, run the simulation from the start (frame 1) since it could need recalculations
  • if something in the simulation seems to be stuck after some settings change, try also to delete (and thus rebuild) the cache

Also, on the above page you can download a "finished" .blend which could help you understand better.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .