1
$\begingroup$

white objects in 3D view

I have a strange problem that I have been hammering for 6 hours now. All primitives with texture assigned to them turn white.

So far I have tried:

  • The texture tab I viewport shading
  • Cycling through all render modes
  • Everything in the shading tab
  • Object color in Object tab
  • Made sure new primitives had UV coordinates

Nothing will effect the primitives, I can't assign material or a texture.

$\endgroup$
3
$\begingroup$

In texture view, you you will see the image from the UV editor, not the image(s) from the texture(s) assigned to the material, as illustrated in the image below.

Open up your texture image in UV editor while you have the UV map open (if that image is already assigned to a texture, you need not load it again, just click the arrows to the left of the word New, and a drop down list with already loaded images will appear).

enter image description here

You can make the same image visible in solid view as well, if you enable Texture Solid in the Shading panel.

enter image description here

$\endgroup$
0
$\begingroup$
  1. While in uv layout, notice the 3d object/model editor on the right window/panel side enter image description here
  2. Select all vertices in 3d editor (press "a" shortcut key) ensure your in edit mode.
  3. All unwrapped vertices should be highlighted (steps to mark seams assumed already done).
  4. Create new uv image (with color grid).
  5. Save and it should show up now.
$\endgroup$
  • 1
    $\begingroup$ what do you mean by "in uv edtior , in left window 3d editor" $\endgroup$ – David Mar 10 '18 at 15:23
  • $\begingroup$ (update: added image) - its the right window/panel apologies :( $\endgroup$ – Den Mar 10 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.