0
$\begingroup$

I defined some glossy planes by specifying the four vertices and vertex order for each. I rendered them in Cycles under an outdoor HDRI lighting. Strangely, some of the planes split into two triangles rendered in very different colors.

enter image description here

At first I thought it was due to surface normals, so I made sure the surface normals all point to the camera. However, the problem persists.

Why is it so, and how may I fix this? Many thanks!

$\endgroup$
  • 1
    $\begingroup$ Is your mesh smooth shaded? It looks like it is flat shaded ,so non planar quads will inevitably show visible sharp edge. Make your mesh smooth shaded, check Auto Smooth under Mesh Data in the Properties Window or add an Edge Split modifier. You may need to manually mark some edges as Sharp in Edit Mode if you have a mix of Smooth and Flat shaded areas in the same object. $\endgroup$ – Duarte Farrajota Ramos Dec 28 '16 at 3:12
  • $\begingroup$ @DuarteFarrajotaRamos Thanks a lot! I just tried enabling Auto Smooth and am having a new (different) problem. I've updated the question. :-D $\endgroup$ – Sibbs Gambling Dec 28 '16 at 4:28
  • $\begingroup$ Try adding an Edge Split Modifier, if that isn't enough try marking smoothness-breaking edges as Sharp under edit mode. If it is still not enough, you may actually need more geometry by subdividing your mesh with a Subsurf modifier, though that will require adding a lot more control loops $\endgroup$ – Duarte Farrajota Ramos Dec 28 '16 at 5:37
  • $\begingroup$ @DuarteFarrajotaRamos many thanks again! As a newbie, Edge Splitting and Sharp sound like the opposite to what I want -- they sound like something that breaks the smoothness? Also, I am actually free to add more geometry to subdivide my mesh, and my computation resources allow for that too. In this case, I can just further subdivide my mesh, right? Does subsurf have more advantages than this? Thanks again! $\endgroup$ – Sibbs Gambling Dec 28 '16 at 5:58
  • $\begingroup$ Subsurf is non destructive, so it can be adjusted dynamically $\endgroup$ – Duarte Farrajota Ramos Dec 28 '16 at 14:03
0
$\begingroup$

For future readers: (TL;DR) This triangle effects can be removed by enabling Auto Smooth under mesh settings.

Credits to @DuarteFarrajotaRamos:

Is your mesh smooth shaded? It looks like it is flat shaded ,so non planar quads will inevitably show visible sharp edge. Make your mesh smooth shaded, check Auto Smooth under Mesh Data in the Properties Window or add an Edge Split modifier. You may need to manually mark some edges as Sharp in Edit Mode if you have a mix of Smooth and Flat shaded areas in the same object

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.