2
$\begingroup$

I can assign a vertex group for the particle density just fine. The problem is when I edit the weights of the vertex group (after I've combed the hair), the hair particles don't update to match. To get it to update, I have to click Free Edit (which, of course, undoes everything i did to that point). Only then does it update in real time with the vertex group. But you can see at around 8:10 on the following tutorial by CG Cookie the hair actually updating AFTER combing.

https://www.youtube.com/watch?v=lxwox9C280Y

What could possibly be wrong? I even tried adding a particle system to a simple plane (completely new file, no other modifiers or anything). It just doesn't work.

Thanks!

$\endgroup$
1
$\begingroup$

Good question! This seems to be a bug in Blender, because if I add interpolated children (like in the video), then the weight painting has immediate effect, but without interpolated children (probably you tried without children or with simple children) it doesn't.

If nobody has a better answer than me, I suggest that you report a bug in the Blender bug tracker.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.