Okay I am very new at this. The texture isn't rendering in the correct places, and in some places there should be a pattern (like spots on his side by his tail). The colors are all messed up and hard to explain, but his tail should be white with a little bit of green at the base by the body. The top of the neck should be green, but the bottom should be the tan. And his face should have green on the top of the snout and tan, with a little white, on the bottom.

I am not sure if when I resized model if that might have messed up the textures.

Any help that can be provided is appreciated.

  • $\begingroup$ Your UV Map doesn't seem to match the applied texture. Either you change the UV coordinates or you changed the texture. $\endgroup$ Commented Dec 25, 2016 at 3:14
  • $\begingroup$ @Duarte Farrajota Ramos : Which one would be easier? And how do you fix the UV coordinates or the texture? $\endgroup$
    – LadyAriel
    Commented Dec 25, 2016 at 3:32
  • $\begingroup$ You most likely unwrapped you object again losing the previous UVmap. Fix it by unwrapping it again properly if that is indeed what happened. Hard to tell from the file alone. $\endgroup$ Commented Dec 25, 2016 at 5:15
  • $\begingroup$ @Duarte Farrajota Romos : I just extracted the model from the game and put the textures in their proper places. I didn't really mess with anything other than resizing the model, since it was 10x the size at first. $\endgroup$
    – LadyAriel
    Commented Dec 25, 2016 at 15:27
  • $\begingroup$ In that case something happened along the process of extraction or import that messed up the UV coordinates $\endgroup$ Commented Dec 25, 2016 at 17:03

1 Answer 1


I don't play that game nor know the extraction software, Collada DAE is quite fine as an export format, something must be wrong with either the Ohana exporter or the Collada plugins, or both.

Jumping through many applications is a recipe for certain trouble, a million things could go wrong, not the very least, bad implementations, unsupported features, or even a plain bug. It's impossible to tell from the file alone.

Rule of thumb is: import the geometry, remake the materials, export file formats never deal well with materials.

Looking at the Blend file it seems that there is some trouble with the mesh symmetry and the texture.

Scaling the mesh 200% in the UV image Editor seems to partially fix the problem and vaguely align the geometry with the texture features. I would advise deleting half of all meshes, and applying a mirror modifier to them so UV are also mirrored automatically.

Enter edit mode on all objects composing the model, select all faces, go to the UV image editor, press . (Period Key) to transform about the 2D cursor location, make sure the 2D cursor is at the origin, press S to scale, press X to scale about the X axis, press 2 by a factor of 2.

Then optionally in the 3D view erase half the mesh with the wrong texture coordinates, and add a Mirror modifier to the object.

Optionally change the Material Specular Shading from Phong to Blinn to eliminate the shading artifacts.

enter image description here

I have no clue what it is supposed to look like, if that is not the intended appearance, then you might have to either import again with different settings or manually fix the UVs by unwrapping again.

  • $\begingroup$ What do you mean by import the geometry and remake the materials? What do you mean by geometry (like the skeleton in the blend file with some animation)? $\endgroup$
    – LadyAriel
    Commented Dec 25, 2016 at 18:43
  • $\begingroup$ No the geometry is the actual shape, the model consisting of meshes. $\endgroup$ Commented Dec 25, 2016 at 19:00
  • $\begingroup$ How do you get the UV image editor to work since when I bring it up it is a blank box? $\endgroup$
    – LadyAriel
    Commented Dec 25, 2016 at 22:13
  • $\begingroup$ Blender UV Unwrap $\endgroup$ Commented Dec 26, 2016 at 0:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .