I have the Radeon R9 280X video card and was wondering if there was anyway at all to enable GPU rendering with this card? I know Nvidia has CUDA cores and that works. That's good and all, BUT I don't feel like dropping $900 on one of those cards.

I did some research on OpenCL with Blender (which seems to be compatible with AMD cards), but it seems the functionality has been disabled within Blender??

I would like to use cycles with the card, but if that is not a viable option then I'll stick with Blender internal. I just hate CPU based rendering. It takes ages to do the renders.

  • 2
    $\begingroup$ You cannot replace Nvidia cuda cores with whatever ati has. You will have to stick to cpu based rendering for now. OpenCL Cycles was planned, but I don't think it will be equivalent to what blender has for nvidia. $\endgroup$
    – Vader
    Commented Feb 11, 2014 at 20:32
  • $\begingroup$ I understand equivalency is not there. I am just wanting to decrease rendering times. $\endgroup$
    – Starius
    Commented Feb 11, 2014 at 20:50
  • $\begingroup$ I don't think that's possible atm $\endgroup$
    – Vader
    Commented Feb 11, 2014 at 21:40
  • 1
    $\begingroup$ Nope, this is not possible in cycles due to driver limitations. Also check the wiki and this thread on BA which as some working tests. Development on BI has stopped and AFAIK there is no support for GPGPU rendering of any kind in BI. $\endgroup$
    – gandalf3
    Commented Feb 11, 2014 at 22:32
  • $\begingroup$ I have the beta drivers if that makes any difference? $\endgroup$
    – Starius
    Commented Feb 12, 2014 at 9:16

3 Answers 3


Blender Internal

BI never had any kind of GPU rendering support, and as development on BI has stopped, probably never will.


Cycles only supports cuda at the moment, due to issues with amd/ati drivers. (also see the wiki)

However, there are some experimental tests using the "leaked beta version of what might be AMD's next official drivers" which you may want to try.


I use 2x r9 280x's cross fired. Just drop down to cmd and use set cycles_opencl_test=all and runn blender.exe from the directory. The 1st scene will take a while to compile so just render the cube. Than open your scene.

I was able to pick up the cards for just under 250 each. I still want to add 1 more to decrease render times.

Hope this helps Raul

  • $\begingroup$ I'm not sure cross fire is speeding up rendering.. SLI (the nvidia equivalent) does not speed up rendering as cycles can use each GPU independently (SLI makes multiple GPUs act like one gpu, actually decreasing performance for cycles). I realize crossfire is probably very different from SLI, but I thought I'd mention this. $\endgroup$
    – gandalf3
    Commented Jun 28, 2014 at 7:41
  1. Install the sdk for your card (AMD should have some sdk for OpenCL)

  2. Create a batch file to replace your blender shortcut:

    cd C:\Program Files\Blender Foundation\Blender
  3. Save as startBlender.bat and run it as administrator

  4. Open the user preferences (CtrlAltU) and go to System tab, set compute device to CPU only (GPU and CPGPU might not work for AMD, you would have to test it yourself)

  5. In the Scene settings set Render > Device to GPU Compute

  6. Set your viewport Shading to Rendered to test it and compare it with CPU compute

  7. Wait first time (Blender needs to compile the OpenCL kernel)

  8. Enjoy faster renders (40 percent at least on my side)

This worked for my Intel card and for Nvidia the OpenCL functionality is included inside the driver, so no SDK download was required, perhaps some other things are required for AMD. I don't know about that, sorry.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .