3
$\begingroup$

What could be causing my plane with glass shader to act like a lens?

I want normal glass, and already have tried 2 different node setups, but it still acts like a lens.

Render: enter image description here

Glass node setup 1: enter image description here

Glass node setup 2: enter image description here

$\endgroup$
  • 1
    $\begingroup$ Any reason you are not using a plain Glass BSDF for a glass material? $\endgroup$ – John Dvorak Dec 21 '16 at 13:22
  • $\begingroup$ you could use the glossy and mix shader with transparent $\endgroup$ – Faceb Faceb Dec 21 '16 at 13:24
  • $\begingroup$ Unless you are looking for an (unrealistic) material that reflects light according to Fresnel's law like glass does, but does not refract? That would be glossy + transparent. I've never touched those IsXRay nodes, and I don't think you need them. $\endgroup$ – John Dvorak Dec 21 '16 at 13:26
  • 1
    $\begingroup$ I'm looking for a node setup that will produce realistic glass, and not act like a lense. Plain Glass BSDF shader doesn't act like a lense which is good but it's not the most realistic way to make glass. I've seen the 2 I've tried being used in realistic scenes, but it's just not working for me. $\endgroup$ – Igor Tatarnikov Dec 21 '16 at 13:30
  • $\begingroup$ Which of the node setups is used for the shown render? $\endgroup$ – PGmath Dec 21 '16 at 16:36
17
$\begingroup$

It looks like the glass object has no thickness. Without any thickness, rays are bent only once, and behave as if everything behind the plane were inside the glass, rather than behind it.

After adding a solidify modifier (or thickness via any other method), rays passing through the glass will be bent upon entering it, then bent back upon exiting it. This should result in the expected appearance:

enter image description here

$\endgroup$
  • $\begingroup$ Nope, unfortunately adding solidify modifier didn't change anything. $\endgroup$ – Igor Tatarnikov Dec 21 '16 at 15:02
  • 4
    $\begingroup$ @IgorTatarnikov: Gandalf3's answer is correct and should work. I'd advise you to check the scale of your scene and check the thickness of your glass. Glass always have refraction, so it will always act a bit as a lens, but the extreme refraction in your example is clearly what gandalf3 pointed out. Check again your scene and make sure your glass isn't just a plane and it has some realistic thickness. $\endgroup$ – Gez Dec 21 '16 at 15:56
  • $\begingroup$ @Gez Ik, it seems legit. But it doesn't solve the problem in my case. And I've used blender long enough to tell if an object has a solidify modifier or not. $\endgroup$ – Igor Tatarnikov Dec 21 '16 at 18:23
  • 2
    $\begingroup$ huh. Is it possible you could upload a .blend exhibiting the material/object in question? $\endgroup$ – gandalf3 Dec 21 '16 at 20:09
  • $\begingroup$ Does it have the normals pointing in the right direction? $\endgroup$ – Gez Dec 22 '16 at 2:03
2
$\begingroup$

You could change the IOR to be 1. Then the light will no longer be refracted. But I think you had that solidify Problem mentioned above.

$\endgroup$
1
$\begingroup$

Well it looks like the light path node going through the math nodes is distorting things. If you just use the glass shader only the problem goes away.

enter image description here

enter image description here

I know the light path node is better for setting up glass but it seems something is off. If you want to keep the same set up so it renders faster with no fire flies try dropping the IOR to something like 1.05 and see if that fixes it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.