56
$\begingroup$

Sometimes the 3d view rotation using the 3rd mouse button starts to rotate around an unusual point that is not very convenient. I don't know why it starts doing this, but it usually starts when I'm zoomed in on a detailed part of a model and persists even after I zoomed out.

I've tried changing the rotation style back and forth from trackball and turntable. I've tried restarting Blender, but that doesn't really help. My main solution to this problem has been to abandon working on the projects that this happens too, which only works because I've been lucky enough to have this happen only on projects that can be abandoned.

Is this changing of the view rotation a common occurence? Is there a way to reset the center of rotation for the 3d view?

$\endgroup$
  • 3
    $\begingroup$ Is the 3d cursor in the middle of the scene? Try using Shift + C to reset it and try again. $\endgroup$ – iKlsR Jun 7 '13 at 3:32
65
$\begingroup$

To re-center the 3D view pivot to a more convenient point, select a vertex (or series of vertices) near the area you're working on and, in Edit Mode, hit Numpad . (the period key on the number pad). The view will now rotate around said element, avoiding those situations where it's nearly impossible to work on an area because you can't get a good look at it (when it rotates too far for you to focus on that area easily). You can also use this shortcut (called "View Selected" in the keymap) in Object Mode to fit the active object in the view and pivot around it.

You'll have to do this every so often as the geometry of your object changes (or the view behavior otherwise gets weird). I recommend using "Rotate Around Selection" under View Manipulation in File > User Preferences > Interface because it makes rotation behavior more predictable.

This shortcut is also helpful when dealing with this problem:Ctrl + Shift + MMB MMB (Dolly View) changes the view center (which the API calls the "Location" component of the 3D view), which is the source of the problem.

Also read this, it explains how the 3D view works and why your problem occurs (Credit to iKlsR for the link): Why does the zoom sometimes stop at a point?

$\endgroup$
  • $\begingroup$ This seemed to do the trick! I also found that when I got really frustrated, if I destroyed the 3d view window and then recreated it, that seemed to restore the proper view rotation. $\endgroup$ – Jason Jun 10 '13 at 13:07
  • $\begingroup$ It seems your link to Dolly View has changed in the manual pages since your post. Way want to update it. blender.org/manual/getting_started/basics/navigating/… $\endgroup$ – Mentalist Jul 4 '15 at 0:24
  • $\begingroup$ Why does dollying change the orbit point? Zooming with the mouse wheel doesn't (and it has the same effect). Dollying doesn't change the orbit centre in Maya so I'm finding it very difficult to get used to. $\endgroup$ – U62 Dec 9 '18 at 11:27
8
$\begingroup$

Since you say you tried switching the rotation modes and that didn't work and your question title speaks about resetting the rotation to the center of the view, you probably more than likely hit the . (period key) by accident (and your 3d cursor is elsewhere), this rotates around the 3d cursor. Just press , (comma) to switch back to the default.

You also say you restarted and the problem still persists, could you have also accidentally saved this as the default? Several possibilities here as this sounds like a localized problem.

If all fails, I suggest restoring the factory defaults by going to File > Load Factory Settings. Then once it has been reset, use Ctrl + U to save this as the new fresh default.

Also see possibly related

$\endgroup$
  • $\begingroup$ I could be wrong in respect to the problem but this is how I understand it from how it's phrased. Let me know so I can bin or keep the answer. $\endgroup$ – iKlsR Jun 7 '13 at 3:28
  • $\begingroup$ blender.stackexchange.com/questions/386/… also has lots of relevant information $\endgroup$ – Gwen Jun 7 '13 at 3:28
  • $\begingroup$ <kbd>.</kbd> and <kbd>,</kbd> change the center of rotation for rotating objects, but not for rotating the 3D view itself. I tried to reload the preferences, but it didn't work. Erics solution below seemed to work, though. $\endgroup$ – Jason Jun 10 '13 at 13:05
  • $\begingroup$ @Jason I am pretty sure, what he has in his answer is the same thing I have here.. ;) You were probably after the Rotate around Selection feature tho. $\endgroup$ – iKlsR Jun 10 '13 at 13:50
  • $\begingroup$ @iKlsR Yes, I believe you're talking about a different problem. Hitting just the period key changes the transform pivot, not the "location" component of the 3D view (which the API describes as the 3D view pivot). But, the links you provided were very helpful, some of these things I didn't know until I read through that link you provided. $\endgroup$ – Qutorial Jun 10 '13 at 14:20
3
$\begingroup$

Maybe setting Auto Depth, pictured below, can help. Per its tooltip, Auto Depth will "use the depth under the mouse to improve view pan/rotate/zoom functionality."

Auto Depth

A bit tricky on wireframes, but it really helped me controlling rotation pivot. Just put the mouse cursor above a surface (easier on a solid-displayed one) before rotating.

You may also want to read the discussion about zooming in perspective mode, here: Why does the zoom sometimes stop at a point?.

$\endgroup$
  • $\begingroup$ This didn't seem to work for my particular problem. To be honest, I'm not really sure I understand what this option actually does, though, beyond it's tooltip's description, anyway. $\endgroup$ – Jason Jun 10 '13 at 13:09
  • $\begingroup$ My answer assumes you're using Orthographic view which is, looking at your preferred answer, not the case :D For a couple reasons, I very rarely work using Perspective view. $\endgroup$ – Adhi Jun 10 '13 at 13:35
3
$\begingroup$

You can also set the view to rotate around the 3D cursor by using the shortcut AltHome, or AltF which also works in sculpt mode around the mouse pointer.

For extra options go to 3D view > Header > View > Align View.

$\endgroup$
2
$\begingroup$

I had been fighting this for some time. Like @Jason, I don't know why it ever changed to something else. But emboldened by the answers above I went exploring. Eventually I hit <alt> period and my 3D view snapped to attention (:-)) around the selected vertex, and a quick test of middle-mouse-button movement showed my view rotated around the selected vertex. So I headed into User Preferences to find out what the Key Binding of <alt> period does. enter image description here

So now I think my slightly better informed way of talking out my problem is that the space_data.pivot_piont was set to something I didn't want and now that's fixed!

$\endgroup$

protected by David Nov 28 '15 at 3:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.