3
$\begingroup$

I have recently run into some trouble with my project files. What happened is that the sd card I had them on got corrupt somehow (my computer did not crash and it stayed plugged into my desktop). When I found that the drive was corrupted, I bought a software program that can recover data from corrupted storage drives and was able to get the files "back". However, whenever I tried to open the file in blender (importing and appending included) I receive the following error: enter image description here

I did a little digging and found that it has something to do with the data structure of .blend files and I'm wondering if there is anything I can do to fix the issue? (Even if it takes some coding).

Thanks in advance for helping out the best you can!

$\endgroup$
  • $\begingroup$ It will depend on what part of the file is damaged. In a new file use File->Append and see if you can copy your object from the damaged file. $\endgroup$ – sambler Dec 20 '16 at 4:17
  • $\begingroup$ Wow, that's odd. I just had the same issue. Missing DNA Block Loading 'C:\Users\mike\AppData\Local\Temp\myFile.blend' failed: Failed to read blend file 'C:\Users\mike\AppData\Local\Temp\myFile.blend': Missing DNA block I'm not using an SD card but I expect that my file got corrupt as well. Last save .blend1 loads default cube recover autosave option loads default cube the file is 28MB. $\endgroup$ – Mike Dec 20 '16 at 4:41
  • $\begingroup$ @sambler I tried that process based on a similar post I seen on this forum that detailed the same issue. When I append and go to the file it either opens up empty or I choose the object and it gives me the default cube. $\endgroup$ – Cornelius Jordan Dec 21 '16 at 1:10
  • $\begingroup$ If you can't see any objects to append then it's not likely that you will find a way to get anything out of the file. $\endgroup$ – sambler Dec 21 '16 at 6:27
  • $\begingroup$ AFAIK this can happen as the result of canceling render while synchronizing objects and then forcing Blender to quit. $\endgroup$ – MicroMachine Aug 24 '17 at 16:49
0
$\begingroup$

If you have enabled the autosave File> Recover auto save.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.