2
$\begingroup$

The default shortcut for "Insert keyframe" is I, which is achieved by holding the mouse over for example the Location Transform, and pressing I. I want to use the Insert key instead.

Even if I overwrite all the shortcuts that are called something with Insert keyframe and/or use the I key, it doesn't work. It's still the I key that is active.

Is there something special about the Insert key that makes it unusable? I noticed "Toggle overwrite" was using the Insert, but even if I turned it off, while all shortcuts were assigned to Insert, I still couldn't insert keyframes.

Anyone has a clue on this?

$\endgroup$
  • 1
    $\begingroup$ I could replace (on Windows) the I with Insert without problems. $\endgroup$ – lbalazscs Dec 19 '16 at 0:44
  • $\begingroup$ @Ibalazscs At least in the User Preferences you cant. Note that Niclas mentioned hovering over a property, then pressing "insert". In all other context's it works fine. $\endgroup$ – Leander Dec 19 '16 at 0:49
  • $\begingroup$ Indeed. Maybe this one is hardcoded and cannot be changed. $\endgroup$ – lbalazscs Dec 19 '16 at 1:02
  • $\begingroup$ Oh that's a pity. Instictively I keep pressing the insert button.. :P $\endgroup$ – Niclas Dec 19 '16 at 17:02
2
$\begingroup$

You can use autohotkey to make the insert key function as the "i" key when Blender is open.

https://autohotkey.com/

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks, since a long time ago I got used to the I key and forgot that Insert would be logical:) I could also use Keyboard maestro for this. $\endgroup$ – Niclas Apr 8 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.