2
$\begingroup$

I made this texture in Blender for my dragon and everything works fine there. Then I import to Unity and the Texture for the top of the right wing goes to the underside and something similar happens with the left tail wing.

This is only my second model so I have no idea where to begin to fix this, and I haven't found anything on Google to help me with my problem.

top right Dragon wing texture is on the under side instead

If you want a closer look

http://z-graves.deviantart.com/art/Problem-with-Model-651390730

$\endgroup$
  • $\begingroup$ did you model that with a mirror modifier? $\endgroup$ – David Dec 16 '16 at 19:53
  • $\begingroup$ I actually applied the mirror before I started painting the texture. $\endgroup$ – Z-Graves Dec 16 '16 at 21:36
0
$\begingroup$

Could it be that the normals of mirrored side of the dragon are facing the wrong way?

If you enable Backface Culling you will see your model as it will appear in Unity.

If you notice a difference in your mesh when Backface Culling is enabled then you probably do have inverted normals.

To fix this, in Edit mode, with all of the dragon selected open the Tools panel and then the Shading/UV tab > Normals > Recalculate Normals.

enter image description here

$\endgroup$
  • $\begingroup$ That solved the problem, seems that's all it needed. I never would have guessed, thanks! $\endgroup$ – Z-Graves Dec 17 '16 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.