0
$\begingroup$

I'm experimenting with hair particles to simulate feathers on a bird. I have painted a texture to designate the color of the individual strands. The texture has a simple node setup with UV texture coordinates, vector mapping, an image texture and diffuse shader. The texture is indicated in the render tab of the particle system. However, the hair particles are not taking on this color. The head and chest should have a green and purple color, but instead the body is a uniform grey. Am I missing something?

enter image description here enter image description here

$\endgroup$
2
$\begingroup$

Having other maps such as normal map will cause all hair to show as black, I duplicate the material and disconnect every texture input other than base color, then assign it as the active material in the particle system to fix this.

I had a similar issue pop up which is unrelated. The hairs had desynchronized from the source mesh and were projecting the UV map in a really bad way. It was using the texture area for the characters mouth and tongue along a good stretch of the back, freaky!

If this happens, Click 'Disconnect Hair' near the top of the particle system setting panel, then after it has changed to 'Connect Hair' click the button again.

Another issue I've had is displaced or outright exploding hair caused by changes to the source mesh, this includes many modifiers and subdivision. Checking 'Use Modifier Stack' did not work for me here, strangely.

$\endgroup$
1
$\begingroup$

Well applying a texture to hair particles is that easy.
All you need is a texture on the emitting object. The hair will use the color of the surface at the point where it attaches.

So you must have something else going on. From your screen shot it looks like you have the material (with the image being used). You have the particle system using that material. But do you have the mesh using that material?

Try a render with the particle system turned off. Does the object have the texture showing?
Particle system settings

If not then that is where your problem is. In edit mode select the correct parts of the mesh and assign the material.
Material tab of the properties window

Without your blend that is my best guess, that when you added other materials for your bird, some how it ended up that the material you are using the with the texture is not assigned to the mesh.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.