0
$\begingroup$

Currently I am trying to make a gun model, however when I bevel the edges this unfortunate even occurs.

Before and after

I have tried using bevel (CTRL+B), Intrude, making edge loops and then Scaling inward all resulting in similar issues. How do I bevel the edge without the faces overlapping each other?

$\endgroup$
2
$\begingroup$

If using Bevel you have 2 general options:

  • bevel the geometry as it is but just at small amount.

    This will add tiny beveled edges on your existing geometry; while using Ctrl+B add just a bit of effect. To ensure that no clamping would happen use Bevel modifier with Clamp Overlap option enabled (or while beveling in Edit mode with Ctrl+B press C to enable the same option).

    May be not the best solution because if there are tiny long quads (which are not good thing in general), they will make clamping occur really fast and thus beveled effect would be barely visible (across all the mesh).

  • dissolve / delete some of the edge loops where they are near to each other.

    This means that you get rid of some edge loops of your model (like those in the bottom part of your mesh) for beveling to work as expected. Once it was done you can add those loops back if you really need them or add Subsurf modifier to subdivide that geometry (depending on the case).

One more option is to smoothen edges of the mesh with Subdivision Surface modifier. Basically it's one of the mentioned techniques in the Keep sharp edges when using Subsurf - supporting loopcuts. Add them in the corners and add modifier. Note that this increases amount of geometry quite much so keep that in mind.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.