1
$\begingroup$

Is there a way to reliably disable mipmapping in the file itself, so that blenderplayer will respect the setting and not interpolate textures?

And no, I'm not making a Minecraft clone.

$\endgroup$
3
$\begingroup$

Mipmaps is a system setting, it would be set by the users startup blend file. Not sure that anyone would recommend overriding a users choice.

To change it you would use python to set bpy.context.user_preferences.system.use_mipmaps

$\endgroup$
  • $\begingroup$ The root reason is that I want to disable texture interpolation. Is there a way to do that in the BGE? $\endgroup$ – Forest Katsch Feb 10 '14 at 16:54
  • $\begingroup$ Actually interpolation is an option for textures in blender render but it is disabled when the game engine is selected. You could try setting use_interpolation for a texture but it may be ignored in the game engine. $\endgroup$ – sambler Feb 11 '14 at 7:17
1
$\begingroup$

This is related to mipmap settings, you can change in user preferences > systems > mipmap

But this only work inside blender.

In game (standalone) you need a script.

from bge import render
render.setMipmapping(0)

related: Python API

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.