0
$\begingroup$

I've got a finished model which is made up of circles on top of circles with a cylinder on the bottom, trying to resemble a pine tree. This is the pine tree.

When i export the model as .fbx with the 6.1 ACII to unity, the model shows up in a wierd way and i have no idea why and how to fix it. It looke like this: This is how it shows up in unity

Thank you.

$\endgroup$
1
1
$\begingroup$

You can preview the backface culling in Blender with the check box in the shading panel. To fix your problem, just tab into edit mode, then hit Ctrl + N to recalculate normals.

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ I already found the solution, I needed to do what you said and then solidify the mesh so that the inner faces are visible, now the outer and inner faces can be seen with no problem. @MrZak $\endgroup$ – user32754 Dec 11 '16 at 1:53
  • $\begingroup$ You actually don't need to solidify the mesh. This adds unnecessary geometry (that isn't good for game engines like Unity); please see my gif. $\endgroup$ – JakeD Dec 11 '16 at 2:02
  • $\begingroup$ I already saw it but I also need the inner faces visible (like if you were looking under the tree) and flipping the normals only makes the outer faces (when you see the tree from the front) visible on the mesh and I need both inner and outer, thanks for your help anyways, it speed up the process of figuring it out. $\endgroup$ – user32754 Dec 11 '16 at 2:06
  • $\begingroup$ The fact is, Game engines uses the Backface Culling to speed up their real-time render engine. You had to enable the double-sided feature in 3D game engines or create the solidified model so you do not see any culled parts. Blender had no part in this. $\endgroup$ – TeaCrab Jul 15 '17 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.