1
$\begingroup$

I made a game but the problem was that I couldn't see any shadows. I researched online and found out that GLSL must be selected. I did this but then everything appeared completely white.

I did some more research and found out that I have to bake (even though I have no idea what baking is). I did so but my tank and my sky box still appeared white.

When I tried to bake them, Blender said "no object or image to bake to". Even the walls that are baked don't show any shadows and yes, I do have a sun.

GLSL mode
GLSL mode

Multitexture mode
Multitexture mode

$\endgroup$
  • $\begingroup$ Can you provide a sample.blend for investigation? (A stripped down file with one or two small texture is fine) $\endgroup$ – Monster Dec 15 '16 at 11:44
1
$\begingroup$

Baking

Baking is a process to generate textures. The texture is build from different camera views. To be more specific a camera gets placed above a face, renders the image and applies the result to a new texture.

This way you get render effects into your texture. E.g. you do not need dynamic shadows, so you can "bake" them into the final texture. It looks like there are shadows, but they are not. This saves a lot of processing power.

Situation

While you can use baked textures it does not apply to your situation. You have textures already.

The problem you have is that your materials are not completely set up. GLSL uses the material and texture settings (see the according tabs in the property view). Multi-texture uses whatever texture you assigned in UV-Editor.

This means when you want to see your scene in GLSL, you need to apply the textures via texture tab. The Multitexture mode likes it as well.

$\endgroup$
  • $\begingroup$ i add my textures in the texture tab only. $\endgroup$ – Parveen Saksena Dec 12 '16 at 15:28
  • $\begingroup$ You might want to switch from texture shading to material shading in your 3D view (the drop down right of the object mode drop down). $\endgroup$ – Monster Dec 13 '16 at 5:10
  • $\begingroup$ i did still doesn't work $\endgroup$ – Parveen Saksena Dec 15 '16 at 10:34
0
$\begingroup$

I once had an issue where my game in the BGE didn't have shadows, only to find out that in order to have the shadows render you have to change the renderer to GLSL BEFORE you make ANY materials/textures for your scene. See if that works.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.