4
$\begingroup$

I have a chain object. And i have a curve it follows. I got it to work for following curve, but chain object is not circles but both parts are more like stretched circles (ovals). Object i made with 2 toruses one rotated 90 degrees and then joined them together. I tried single torus too. But same issue. on a curve it just looks stretched oval. What can be the issue?

Thanks

$\endgroup$
  • $\begingroup$ can you upload file? blend-exchange.giantcowfilms.com $\endgroup$ – eromod Dec 9 '16 at 2:22
  • 1
    $\begingroup$ Dont use the curve modifier directly on the torus. Use the torus as dupliface on a plane with the array and curve modifiers instead $\endgroup$ – Duarte Farrajota Ramos Dec 9 '16 at 2:29
  • $\begingroup$ I forgot to say that that i have 2 active modifiers. One is array and other is curve. $\endgroup$ – notverybright Dec 9 '16 at 2:38
14
$\begingroup$

The curve modifier distorts the objects, that is the intended behavior. If you want an undeformed array use either Duplifaces or a particle system instead.

Add your Array+Curve modifier stack to a simple plane mesh instead.

Create a new plane mesh, parent one single chain link to it and activate Duplifaces on the plane's object properties.

Then add the array modifier, use an empty object rotated $90º$ to introduce rotation to each link. Activate the Object Offset option and pick the empty.

Adjust spacing and settings as desired, and then add the curve modifier exclusively to the plane object alone.

Array+Curve+Duplifaces

Alternatively use a particle system instead of Dupligroups feature with one particle per face if you wish to hide the original link independently. Manually adjust particle count to match the number of arrayed links.

$\endgroup$
  • $\begingroup$ ok i followed this animation but when i use array it only multiplies the plane $\endgroup$ – notverybright Dec 9 '16 at 3:11
  • $\begingroup$ But I thank you for taking your time. i will see some tutorials and info about dublifaces and hopefully can figure out what to do. Thanks a lot $\endgroup$ – notverybright Dec 9 '16 at 3:53
  • $\begingroup$ You have to parent the torus to the plane $\endgroup$ – Duarte Farrajota Ramos Dec 9 '16 at 5:10
  • $\begingroup$ How do you stop the plane from being rendered? $\endgroup$ – Jammer Nov 21 '19 at 20:40
  • $\begingroup$ Which part didn't work for you in 2.8? I just managed to follow along just fine. Also if you search you will find what you seek blender.stackexchange.com/questions/118835/… $\endgroup$ – Duarte Farrajota Ramos Nov 22 '19 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.