I'm working on a Photorealistic 3D remodel of a room in my house, and i've run into a problem. The wall and window frames are noisy to the moon and back. I'm not sure why exactly. I'm using the PBR Dialetric material Andrew Price made a video on for both the Window frame and Wall paint. The floor isn't using the PBR material and renders just fine. I want the wall paint to be yellow, and have a tint of glossy shader thrown in there.

Below you will find all my nodes explained to the best of my ability.

enter image description here enter image description here enter image description here

Oh, and here's the floor material:

enter image description here

Aaaaannnddd the lighting setup: enter image description here enter image description here

Any why not throw in the .Blend while we're at it? The file exceeded Blend-Exchange by 1.1mb so I'll have to use Google Drive instead.

  • $\begingroup$ It looks like you have a lighting issue more than a material issue. Can you post a picture of your scene so that we can see your lighting setup? $\endgroup$ Dec 7, 2016 at 4:02
  • $\begingroup$ @ScottMilner I made the changes $\endgroup$ Dec 7, 2016 at 4:09
  • 2
    $\begingroup$ You seem to have your normal map attached to the reflection input in your node group? $\endgroup$
    – JtheNinja
    Dec 7, 2016 at 4:11
  • $\begingroup$ @JtheNinja that is there to add texture to the reflection. I'm basing this scene off of my real-life living room, and The wall itself isn't perfectly smooth, there are bumps and overpaint in areas. The normal map is there to kinda simulate that. I have tried rendering with the normal map detached and still get the same problem. $\endgroup$ Dec 7, 2016 at 4:14
  • $\begingroup$ The Normal Maps themselves are fine, but their UV maps aren't linked up. That changes it, but doesn't solve the problem. $\endgroup$ Dec 7, 2016 at 4:14

1 Answer 1


Your problem is your lighting. Since your only sources of lighting are the windows, Blender is having to compute a lot of bounces to get light the room, which results in a super grainy render. The first thing to do is to add light portals. These will direct Blender toward the windows for light.

  1. Add an Area lamp. Position and rotate it directly behind your first window, pointing in, and size it just bigger than them. Change the shape to rectangle, and size it to fit the window. Check the "Portal" box.
  2. Duplicate it and move it to the other windows. (For convenience, since they are all the same size, you can do a linked duplicate Alt + D.)

The above should help you get more light from your sun. However, you still don't have enough light overall in your room. I would add some other lamps either on the ceiling, behind your camera, or anywhere there is actually light (since you are replicating your own living room).

Also, since you are using an HDRI, enable "Multiple Importance" under the "Settings" panel in the "World" tab.

One last thing you can try is to increase the Max Bounces underneath the "Light Paths" tab. This will force Blender to calculate each light ray further, but this is very computationally intensive, and will do relatively little for you compared to other options.

EDIT: I just looked at the number of samples you are using, and those are crazy low. Crank those up! 50 at least!

  • $\begingroup$ I added the portals, and that does seem to help a bit. I will add in the other lamps and lights that are supposed to be there once I get to that point in modeling. And I have low samples because I have just been using the "Final" Sampling Preset, assuming it was enough. $\endgroup$ Dec 7, 2016 at 4:41
  • $\begingroup$ This solved the problem- looking much better now. i.gyazo.com/b140ac76c7b8e706fc1570f99f100484.jpg $\endgroup$ Dec 7, 2016 at 19:46
  • $\begingroup$ Glad I could help. Looking good! $\endgroup$ Dec 7, 2016 at 23:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .