3
$\begingroup$

I'm trying to make grass and a house, but, the grass just grows through the floor. How can I remove the grass where it is touching the building. there is supposed to be a floor in the house but the grass just goes over it

$\endgroup$
3
$\begingroup$

I am guessing you are using a hair particle system for your grass. If so: Use a vertex group and weight painting to control placement of grass (and its length, if you want; see : Increase Intensity of Vertex Group ).

In edit mode, subdivide the mesh on which the grass is placed, select the mesh squares outside of the house and assign them to a vertex group. You can control the placement even more if you then switch to weight paint mode.

enter image description here

This use the vertex group control in your particle system to place the grass only in the vert'ed areas.

enter image description here

You'll end up with something like this, but prettier):

enter image description here

Also related, particularly about finer placement of hairs:

How do I make hair particles appear on top of the emitter and not through it?

Hair renders from regions outside vertex group

$\endgroup$
2
$\begingroup$

Another way would be to use texture to affect hair particles density. If painting that texture directly, make sure to unwrap the mesh, paint the texture (white - where the grass should be, black - where should not, you can invert colors in UV/Image Editor):

screenshot of texture setup

Then assign it in the textures panel of the particle system settings (as it should be hair type). Make sure to set Mapping to UV map you created, uncheck Time in the Influence rollout and check Length under Hair section:

screenshot of the particle system setup

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.