2
$\begingroup$

Sometimes when I animate the strength of some sort of lamp or material, the keyframes for it appear in the dopesheet. This is useful especially when using the "display selected only" button. It makes it precise and clear to see what I am doing while animating.

Sometimes they appear in the dopesheet, but NOT with the selected mode. This is annoying, for I have to search the keyframes in huge amounts of channels and stuff. Almost impossible to work that way.

And sometimes they don't appear at all. Which is ... I don't have words :)

It might also happen, that they first appear, and after changing something (I have no Idea what) I can't use the 'selected only' tag anymore.

$\endgroup$
  • 1
    $\begingroup$ Please post an image that shows your dopesheet, including the icons on the bottom. $\endgroup$ – cegaton Dec 6 '16 at 14:45
1
$\begingroup$

What you describe is the way blender works. The only selected option is just more specific than you are expecting. For the keyframes of a value from a node to be displayed the node has to be selected in the node tree as well as the object using the material being selected. So when animating objects and armatures the only selected option works rather well but for animated node values it can just make life difficult.

When not using only selected, you have other filter options to help find what you are working on. The datablock filters let you show just nodes (you want both material and nodes for material nodes). Clicking the magnifying glass shows a text input that lets you filter by channel name, you can also use ⎈ CtrlF and type the search string or clear it out to remove the filter. There is also an option to sort alphabetically but you will find it works on the object names and not each channel name.

filter options

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.