0
$\begingroup$

It seems like the emission shader lights up other objects stronger in the preview render than in final renders.

Preview Render Difference

I'm using mesh lights in Blender 2.78. The error is reproducible by creating a plane with an emission shader and a subject with any kind of material, that's lit by the plane.

Lamp Material

As I didn't find any reports of this issue, I'm wondering if I'm the only one experiencing it, and if so, what settings might cause this.


EDIT:

After resetting the preferences in the System tab this is the render: Render After Adjusting Preferences

It is a bit closer to the preview, but then I noticed that both of the lights are reflected two times. (Which was visible before, but I didn't realize it.)

I also tried to render with CPU, and the result was identical to the preview.

So it's definitely a problem with the GPU (Nvidia). It's unlikely a driver problem since I noticed the problem some weeks ago.

$\endgroup$
  • $\begingroup$ hmm..here it looks the same. Try File->Load Factory settings. Maybe you have set something in the userpreferences or something.. $\endgroup$ – 3Descape Dec 6 '16 at 13:39
  • 1
    $\begingroup$ Have you applied the scale to your mesh lights? $\endgroup$ – Delagone Dec 6 '16 at 14:31
  • $\begingroup$ I did now, but it didn't fix it. $\endgroup$ – Cebbi Dec 6 '16 at 14:46
0
$\begingroup$

I tried Delagone's comment without success,

Have you applied the scale to your mesh lights?

but later I could fix the problem by also applying Rotation and Location.

I don't know what the GPU thinks the lamps looked like, but without all three transformations applied, the rendered image was wrong in some way.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.