0
$\begingroup$

I have an extruded surface, but its generated texture coordinates are distorted as shown. If I choose UV coordinates, the mapping is correct. However, what do I need to reset so that the generated coordinates will work as usual?

enter image description here

$\endgroup$
  • $\begingroup$ Generated texture coordinates are probably projecting from the wrong direction, you have to adjust them using a Vector Mapping Node $\endgroup$ – Duarte Farrajota Ramos Dec 3 '16 at 1:22
  • 1
    $\begingroup$ As you show plane with a texture shown in viewport and want to use Generated texture coordinates, I suppose you use Blender Internal. In this case, texture coordinates can be adjusted in Mapping rollout in texture settings . I can also assume that your plane is rotated along Y axis. $\endgroup$ – Mr Zak Dec 3 '16 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.