0
$\begingroup$

I have a problem. When I import a stl file from solidworks into blender for rendering it doesn't match the scale of the scene. It is gigantic. The object is a chair and I have checked the scale in solidworks and here it is ok. Hope someone can help.

Thanks

PrettyP74

$\endgroup$
  • 1
    $\begingroup$ Can't you just scale it down? $\endgroup$ – piegames Dec 2 '16 at 19:42
1
$\begingroup$

There is no scale information in STL file format the units are arbitrary.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi. I don't understand.... My chair has been modeled in 1:1 in solidworks - but when I import it (stl file) into blender to do renderings it is just enormous and seems too big to do anything. Could it be some settings in blender that I have to change? PrettyP74 $\endgroup$ – PrettyP74 Dec 2 '16 at 21:05
  • $\begingroup$ The STL file does not tell blender how big the item is. When you import the model in blender look at the import settings. These settings appear in the lower left of the screen, the Scale setting is the one you want to change. Try setting it to 0.1 or 0.01 and see how the chair looks. $\endgroup$ – Samir Rahamtalla Dec 2 '16 at 21:26
  • $\begingroup$ That helped a lot. Thumbs Up ! $\endgroup$ – PrettyP74 Dec 3 '16 at 7:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.