I'm doing a retopology of an object, which has vertical cracks. I used a clipping border (Alt+B) to display only one half of the mesh and tried to retopologize the crack, but all the vertices are snapping in a wrong way. How to fix it? enter image description here

  • 2
    $\begingroup$ Not really a solution, more of a workaround, but maybe separate the mesh parts into multiple objects, and isolate with Local View? $\endgroup$ – Duarte Farrajota Ramos Dec 1 '16 at 22:30
  • $\begingroup$ Interesting situation. As I tested it snaps vertices to the opposite side of the mesh because it remains visible inside of Clipping Border while mouse with vertex is hovered over that area. Although I couldn't get that behaviour, maybe it's worth trying to hide everything but selection (Shift+H) ? $\endgroup$ – Mr Zak Dec 1 '16 at 23:35
  • $\begingroup$ Thanks for suggestions guys. I changed the snap element type to Vertex and it works (dunno why it doesn't for a Face type). It's not as precise though- maybe I should report it as a bug? $\endgroup$ – Paul Gonet Dec 8 '16 at 14:05

You got "Snap during transform" enabled (magnet icon) and when you're moving vertices with "G" it snaps them to the nearest surface (cause you have also Face as the type of element to snap to enabled) As this are edge vertices, and you're doing it from considerable distance, it snaps not to the edge faces but to back faces. I would suggest you to try disable first one and snap vertices with CTRL. It would also be helpful to decrease distance to increase accuracy or hide back faces of high poly model to avoid snapping to the wrong ones. You could do it with mask modifier for example.Options, which I'm talking about are selected in the image.enter image description here

| improve this answer | |
  • $\begingroup$ Thanks for suggestions man. Tried to snap with Ctrl as you mentioned but it doesn't work. I changed the snap element type to Vertex and it's working nice now, however it's not the full solution I wanted. Thanks anyway. $\endgroup$ – Paul Gonet Dec 8 '16 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.