1
$\begingroup$

I run a 3 monitor setup. I'm on windows 7 with 3.4ghz quad core, 32gig RAM, Titan GTX, and 770. My primary monitor is on the Titan, and the secondary 2 monitors are on the 770. I have been used to running my 3D viewport on the main monitor, and a secondary window on the 2nd monitor (usually node editor) and then a web browser on the 3rd monitor.

My second monitor recently took a knock and started having problems, so I got a new one. The new monitor has become the primary monitor, and the previous primary monitor is now the 2nd monitor. And now, whenever I put a second blender window on the 2nd monitor, it lags horribly and is unusable. If I put it on the 3rd monitor, it works fine (but that monitor is small, so I don't want it there.) Other programs work fine on my 2nd monitor.

What can I do about this? Nothing else about my setup has changed. All drivers are up to date.

Update: If I switch to a basic theme, the problem goes away. But why is this suddenly necessary when I never had this before?

Update 2: I have noticed that monitor 3 runs things just fine with no lag. I vaguely remember in the past when I had a different 3 monitors with an older setup (had a 580 instead of Titan) I had the slowdown issue, but on monitor 3 instead of 2. Perhaps it is able to run 2 monitors without slowdown, and my resuffling of monitors means the poor performance is now on current monitor 2, when before it was on monitor 3?

$\endgroup$
  • $\begingroup$ Becus it used to work fine and you haven't updated blender it is probebly not blender. You should poste it in superuser or another computer focused forum. $\endgroup$ – Alfons Marklén Dec 1 '16 at 11:38
  • $\begingroup$ @AlfonsMarklén It is an issue that exists only within Blender. None of my other programs are having problems. It is something to do with how Blender is interacting with the rest of the system. And on google I can find other examples of people asking about the same problem with Blender over the years, but none have solutions. If I post a question relevant to only a single program on SuperUser, they'll just send me back here. $\endgroup$ – Drudge Dec 1 '16 at 11:42
  • $\begingroup$ Then you should talk to one of the devs and see if they can fix it $\endgroup$ – Alfons Marklén Dec 1 '16 at 11:44
  • $\begingroup$ Is the new monitor the same resolution as the old one? $\endgroup$ – cegaton Dec 2 '16 at 16:12
  • $\begingroup$ @cegaton Yes. And hooked up to the exact same port with the same cable even. $\endgroup$ – Drudge Dec 2 '16 at 22:10
1
$\begingroup$

I still don't know the answer to the overall issue, but I have found why this occurred for me specifically.

First, turning off Windows Aero (or doing anything that disables it) will solve this problem. With Aero on, it seems that I get normal performance on 2 of the 3 monitors. In the past, my web browsing monitor was the odd man out. After some flipping things around, I found that whichever monitor was plugged in second (out of 3) will be the one that has issues. So un plugging and re-plugging the screen I wanted good performance on solved the problem, even with Aero enabled.

There must be a lot of variables going on behind the scene that I don't understand, so if anyone ever figures that out I'll be happy to pick a new answer. But for now, this does shed some light on the situation.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.