I'm trying to use Blender v2.78 on my new notebook which has the following config:

CPU - i7-6700HQ (4 cores)

Mem - 16G

GPU - GeForce GTX 1070 (driver is updated to the latest 376.09)

OS - Win10 64bit family version

Immediately opening the software, I'm experiencing lag everywhere interacting with the software UI, almost lag for every basic operation with mouse/keyboard.

I did some search on the web and tried several things:

a. changing user preferences -> system -> window draw method (as well as some other parms that look possible to help for me)

b. setting up 3D parameter via my Nvidia control program, turning on whatever possible for blender.exe

c. running a previous blender version, say v2.77/v2.76b

But the problem still there, not smooth not at, very frustrating.

What's interesting (and somewhat ironic) is my old laptop which is a ThinkPad x1 carbon (win7) with just integrated graphic card can run the software smoothly, no lag at all when operating or editing in the UI though its performance is too low to render the scene quickly and beautifully.

I'm not sure what to do to make it work well for my new notebook. Appreciate if anyone could suggest and help on this.

Thanks very much!

  • $\begingroup$ i have exactly this problem all of sudden, i think we have to downgrade the nvidia driver because i have not done anything to the software just have updated the driver. my card is 960m $\endgroup$ – Hossein Amini Dec 1 '16 at 8:04
  • $\begingroup$ Okay, I just spent some more hours to experiment all kinds of setting possible with the blender software as well as my Nvidia setting for the software. Luckily enough, after rebooting my windows system, the problem gone! So I suppose it would be something not to take effect until after a system reboot. It's really strange but good it's working for me now. $\endgroup$ – fuxiaox Dec 1 '16 at 9:08

Okay, after some more efforts experimenting all sorts of setup, I finally get rid of the problem. I couldn't say which is the exact right action to take to have the problem resolved, but the followings altogether are supposed to be the keys to solve my problem:

  1. Like many on the web said, I changed some User Preference -> System settings, mine looks like below now: enter image description here

  2. I configured my Nvidia control program to turn on everything for blender.exe:

enter image description here

Sorry for the Chinese version, but the Nvidia control panel can be called from the right-click menu on the desktop.

  1. Rebooted my windows. I thought I could have tried reboot earlier...anyway, something needs the reboot to take effect.

Hope this can help whoever has the same problem as mine.


  • $\begingroup$ Sorry, I have to report back that the problem comes back again...pity. it worked for me this afternoon, but when I shut down the system and started windows again in the evening, the problem came back again, weird, weird, weird. $\endgroup$ – fuxiaox Dec 1 '16 at 15:22
  • $\begingroup$ Ok, I downgraded my nvidia card driver and it has been working fine since then. $\endgroup$ – fuxiaox Dec 12 '16 at 11:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.