This has been confirmed resolved in a later version 376.33 and possibly the update prior. meta

Okay, I recently did a computer update. I used to run Blender 2.77 on a Dell desktop (5 GB RAM, 2.7 GHZ, Windows 8, build in graphics card). Since that computer wasn't fast enough for my preference, I saved up and got a new gaming laptop - the Asus ROG GL552 (Windows 10, 16 GB DDR4 RAM, Nvidia GeForce GTX 960M with 4 GB DDR5 RAM, 2.6-3.5 Ghz, and quad-core intel processor). That laptop has been known to have outdated drivers, so when I got it, I updated it to up to date Windows 10 drivers.

As soon as I started Blender, I immediately noticed its speed. Even doing simple things, like clicking buttons, or rotating the view with the middle mouse button, took too long to register in the program. I tried changing some User Preference System settings, but that didn't really help much. And the hardware seems to be fine - the render is lightning fast (renders the startup scene in under .1 second; it's just laggy when loading the uv screen), so I don't know why it's like this, or what to do. Also, I ran Blender 2.77 on this computer, and it was also slow (although it was fine on my previous computer).

It could be an issue with drivers perhaps (or maybe OpenGL?), but I ran Unreal Engine 4, and had none of the same issues - the speed was pretty decent on that; so I'm not sure why Blender would be so slow. Any help is appreciated - thanks guys!

  • 1
    $\begingroup$ Try going to File > User Preferences > System > Window Draw Method and change it to something else other than the default value. Play around with it restarting Blender between changes see if any of those work better. $\endgroup$ Commented Nov 30, 2016 at 20:08
  • $\begingroup$ Sadly that didn't fix it :( $\endgroup$ Commented Dec 1, 2016 at 17:26
  • $\begingroup$ Same solutions as below, I updated my XPS 15 (same 960M) to latest drivers and Blender is unusable. Rollback for now or force using the intel chipset which I wouldn't recommend. $\endgroup$
    – iKlsR
    Commented Dec 2, 2016 at 5:26
  • $\begingroup$ See the current driver release thread here, the problem has been mentioned several times. Will personally monitor and update here forums.geforce.com/default/topic/978895/geforce-drivers/… $\endgroup$
    – iKlsR
    Commented Dec 2, 2016 at 5:33

3 Answers 3


I found the solution, right click on the blender shortcut>Run with Graphics Processor>Integrated Graphics. It should run smooth when you do that. No need to roll back any graphics drivers, just use your integrated graphics to model and you can still set your 960m to render in the settings.

In case you are not able to see the option, Open NVIDIA Control Panel, from the Desktop menu and check 'Add "Run with graphics processor" to Context Menu'

  • $\begingroup$ Had the same issue on my Alienware 15 R2, which is stacked nicely. But right after the driver update, things went into snail mode. Tyler N hit the nail on the head, run it with the integrated graphics and it immediately went back to fast and smooth! $\endgroup$
    – Laon8or
    Commented Dec 5, 2016 at 1:47
  • 1
    $\begingroup$ U da man!! Thank you so much, Tyler - I did that and had to open the Nvidia Control Panel. I then added Blender to the list of programs to customize graphics settings - and it worked!! Thank you so much again! $\endgroup$ Commented Dec 6, 2016 at 20:01
  • $\begingroup$ But will that make Blender rendering any slower since it's not using GeForce graphics to run the program? $\endgroup$ Commented Dec 6, 2016 at 20:04
  • $\begingroup$ @josepharaoh99 it shouldn't, the i7 6700hq should run the program fine with the hd 530 integrated graphics when you're just modeling in solid mode; as long as your projects aren't crazy intensive, it should work fine. Just make sure you use your 960m when rendering by going to File>user preferences>System>compute device>cuda and then in if you're in cycles mode, make sure you change device from cpu to gpu compute under the render drop down menu under the properties panel on the right side of the UI. I'm using the same ROG laptop as well but with 2GB of vram, and blender is working great so far $\endgroup$
    – Tyler N
    Commented Dec 8, 2016 at 1:29
  • 1
    $\begingroup$ There is no such option for as "Run with Graphics Processor" in the NVidia control panel for Desktops. $\endgroup$ Commented Jul 8, 2017 at 16:15

I don't have enough reputation to comment on Sam's post, but he's right. I wanted to stream a game last night and downloaded Nvidia's Geforce Experience for Shadowplay (which updated a driver). Opened Blender this morning and had the same issues (extremely delayed input). Rolled back the driver and working fine again!

  • 5
    $\begingroup$ Ironically, this answer might get you more than enough reputation to comment lol. $\endgroup$
    – 10 Replies
    Commented Dec 3, 2016 at 2:07
  • $\begingroup$ Yeah, it worked. If we speak about this driver, I wonder also if You guys have sometimes vertical lines showing on screen after update? $\endgroup$ Commented Dec 6, 2016 at 1:37

Have the same computer specs on a Dell 7559. Had the same problem when I updated the NVidia drivers to the recent Geforce Experience ver 376.09. I finally uninstalled this driver and went back to the ver 375.95 and things are back to working. Hope this helps!

  • $\begingroup$ Unfortunately, the 375.95 driver doesn't support Windows 10, and I'm very uncertain about changing to out-of-date drivers (because it might cause problems on my computer), but I'm willing too if I can find a W10 one known to work with Blender. $\endgroup$ Commented Dec 6, 2016 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .