2
$\begingroup$

I'm using Blender 2.78a. I've got an object I modelled ready for texture painting. Its already got seams, and been UV unwrapped. The UV map looked alright to me. I set a material for the object. I changed the 3D viewport to texture paint mode. This is with the Blender Renderer. I get no errors, and the texture paint palette and such shows up on screen. But even with everything linked, and no errors.. if I try to paint on the 3D viewport object, or if I turn the UV map to paint mode and try to paint on it.. nothing happens. I'll link to the .blend file, hopefully someone can tell me what setting I've missed or texture I've not set, whatever's wrong. Thanks.

.Blend file here

If the download doesn't come out right, I may have to send the file directly. Something's wrong with the way drop box is trying to handle the file! I tried to save the file directly, and what I got back was only the default blender scene! So if the resulting file isn't a little over 800k, something went wrong!

(Update: I actually found the influence options mentioned in the comments! It is the 'texture' tab on the rightmost shelf, and it is a section near the bottom called of course 'Influence'. What boggles my mind now, is that it was in fact set that the texture affects the rendered normal of the geometry. When it should default to affecting the color! I have no idea why, I can assure I never touched that setting until now!)

$\endgroup$
  • $\begingroup$ Your texture paint setup uses texture for the TextDraw bursh, but nothing is assigned to that texture.. So nothing will be painted unless you choose which texture to use as a brush (or remove it altogether). Keep in mind also that texture set up to be painted on will show only bump but not color because that's what assigned in Influence rollout. $\endgroup$ – Mr Zak Nov 29 '16 at 14:36
  • $\begingroup$ It shows how new to Blender I am. Where is this influence located at? You're correct.. it does not color, it only creates bump-map-like texturing. Which is entirely what I do not want! Thanks for pointing this out, by the way. $\endgroup$ – Monolith Tyriss Nov 29 '16 at 14:41
  • $\begingroup$ As a side note, if your .blend files are less than 30 mb you're very welcome to use blend-exchange service for uploading them. It will provide users here with a copy of your file as long as question is available which makes it easier to understand and to learn from. $\endgroup$ – Mr Zak Nov 29 '16 at 15:09
1
$\begingroup$

First, texture which is meant to be painted on is set up to not affect color rather than bump via Textures tab > Influence rollout:

screenshot of texture tab > Influence rollout

Uncheck Geometry and enable Color in Diffuse section instead to paint with desired color instead of bump.

Second, brush which is used for painting on that texture uses another texture for brush pattern:

screenshot of brush pattern setup

However nothing is assigned to that texture choosed to be used as a brush pattern; hence nothing will be painted.
If you'd like to paint with some brush pattern choose a desired image in Brush textures shown on the right of the screenshot above. If nothing is needed to be affecting the brush, unlink that datablock from the texture painting brush settings.

$\endgroup$
0
$\begingroup$

Go to Texture tab and select the third button (other data textures).

Then assign the texture in the Image slot.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.