0
$\begingroup$

I've made a map for my game which the player can run about and also enter a cave, however the issue is that when I have the faces facing out, the cave becomes invisible and when I flip the faces the other way (using the ctrl+shift+n method in editing in blender) it makes the top/surface of the map invisible, showing the bottom of the map.

I would like to know how to make both sides of the mesh visible in Unity or blender to avoid this issue and due to copyright I cannot upload the file as it's for an upcoming game.

I'm asking this because everything I've looked at and tried hasn't worked for me :(

This is a screenshot to show what happens when I try backface culling: Property of CraftyMaelyss

$\endgroup$
0
$\begingroup$

In Blender you can turn on Backface Culling in the shading tab of the Properties sidebar of the 3D View.

In Unity you need a special shader that can do Backface Culling. This feature is not transferable. Or you simply double the geometry, and flip the normals for one of the meshes then.

enter image description here

$\endgroup$
  • $\begingroup$ I tried this too and unfortunately it had no effect :( $\endgroup$ – CraftyMaelyss Nov 28 '16 at 9:34
  • $\begingroup$ It should. Can it be that you mean something different then? As told, when everything else fails then you can also work with two meshes, one with flipped normals. $\endgroup$ – Tiles Nov 28 '16 at 11:41
  • $\begingroup$ I heard about that method and tried it too but it still behaved like it had normals only on one side. Unfortunately it didn't work as it just turns the faces inside and makes the external invisible, giving the same effect as if I'd just used the Ctrl+shift+N method to turn the faces in :( I've added a screenshot to show what backface culling does in blender as it's still showing up in Unity with pieces missing. $\endgroup$ – CraftyMaelyss Nov 29 '16 at 0:57
  • $\begingroup$ Have you understood that you use TWO independant meshes with that method? - As for your screenshot, it looks like some of the normals are flipped. In that case do a recalculate normals. $\endgroup$ – Tiles Nov 29 '16 at 9:33
  • $\begingroup$ Yes I actually said that in my answer, since it's a temporary fix around the problem. As I already said I tried recalculating the normals and it gave me the same result as backface culling, which is why I uploaded the screenshot so please do not talk to me so rudely. I'm still learning and most of the time I have to play around with settings to figure out how these things work when hours of googling, searching through forums and watching hours upon hours of tutorials don't work. I post these here since I'm sure other people also get stuck on these and it helped me so it might help others $\endgroup$ – CraftyMaelyss Dec 1 '16 at 4:07
0
$\begingroup$

After playing around a bit with Blender I was able to find a solution to the issue and I'm posting this here so it can help others too:

What you want to do is to make the external model(the main map) separate from the internal model(the cave) then go into Unity and put the model in. When you click on the model in Unity it will show you where the missing pieces are.

Using this as a reference, go back into Blender and delete the faces that are causing issues, then add more vertices and faces, save it, then go into Unity.

Delete the current model from Unity then re-import it(clicking re-import doesn't work for some reason) and check again in the model view. If you fixed it, you should be able to see the missing faces are covered either partially or completely. Keep doing this until your model no longer has any missing faces.

As for the cave or internal model, go into edit mode and press ctrl+shift+N to bring up the normals menu and simply check the box that says "inside".

This will make the faces visible on the inside of the model. Once you do that, just put the internal model inside the external, add a few faces, vertices and edged to connect them, flip them the right way and you're done :)

I hope this helps people as I was pretty stumped with this for a while :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.