0
$\begingroup$

Whenever I try to open a .BLEND file, instead of opening the file like it should be doing, It instead just opens a new scene? For example, you save a large cave scene, but when you open it by clicking on the file it just opens the default 'New Scene'.
Edit: Ok this just happened, enter image description here

I went into regedit to make sure things are correct and they are, so I have absolutely no idea what's going on.
Edit again: for some reason the program became unknown in the associated file types. So that is fixed, but it is still just opening a new scene.

$\endgroup$
  • $\begingroup$ And if you try open blender.exe, file > open? $\endgroup$ – Faceb Faceb Nov 25 '16 at 21:19
  • $\begingroup$ It will open the scene normally. $\endgroup$ – Jollicus Nov 25 '16 at 21:20
  • $\begingroup$ are you sure you don"t try to open a .blend1 or .blend2... autosave file? $\endgroup$ – Bithur Nov 25 '16 at 22:46
  • $\begingroup$ can't open those, it just gives me a prompt to look online for a program or to delete it. $\endgroup$ – Jollicus Nov 26 '16 at 0:23
  • 3
    $\begingroup$ My fundamental inclination is to vote to close this question as "off topic", because it's about a Windows operating system issue, not a Blender one. But I recall having seen the same question asked multiple times previously, and it seems expedient to provide at least one answer. $\endgroup$ – brasshat Nov 26 '16 at 2:49
2
$\begingroup$

I have the same issue, and I suspect that your notion that you downloaded the zip file rather than the installer is, in fact, the cause of the problem. It appears to me, that you are using a recent version of Windows. In which case, you can try clicking on "start", and in the menu interface, click on "Default Programs" (in my installation, in the right hand column, directly above "Help and Support"). In the resulting menu, click on "Associate a file type or protocol with a program", which will bring up a list of most of the file types present on your system, perhaps after a period of time to load. In the list, right-click on the Blend extension, and in the upper right hand corner, click on the "change program"

In my installation, when I do this, there is no option to associate the file with Blender, despite the fact that I have about a dozen versions of Blender present on my machine. But each of these is in a separate folder on the desktop of one particular user (I have a half dozen set up, each associated with a particular activity), so that it might be that Windows apparently does not see that the executable programs in those files. It might be that if the unzipped folders containing the various Blender versions were in the root directory of the drive on which they are located, instead of the desktop folder of a particular user, that Windows might be able to see them.

My workaround is to open an instance of Blender, and open new projects from there, and use "open" from the Blender menu to open existing files, and if it's a project I have previously worked on, to use the "open recent" option.

$\endgroup$
  • $\begingroup$ I've done this multiple times, even reconfigured the Registry Key and played around with directories, properties, administration access, etc to see if that is the cause of the problem. But otherwise, I agree with brasshat, this is a windows issue for the most part and shouldn't be here. Thankfully I at least know the root of the problem. $\endgroup$ – Jollicus Nov 26 '16 at 3:36
  • $\begingroup$ see: blender.stackexchange.com/a/41488/1853 $\endgroup$ – cegaton Nov 26 '16 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.