2
$\begingroup$

I have a model with only 98 vertices. When I export it to Collada with Blender 2.64, it generates a Cube_001-mesh-map-0-array with 768 entries, that is, 384 UVs. I've checked the UV map, but it doesn't complain duplicates, so I don't understand why...

I tried updating Blender to 2.69 and now it got worse. When I export it now I get 1152 entries, 576 UVs.

Is this the expected behavior? I am trying to keep the vertex data to a minimum for my game, but this doesn't help...

Edit: I just realized that the difference between 2.64 and 2.69 is that now all the polygons are triangles instead of quads, so it seems it adds more UVs to cover them... But I debugged it and there are many duplicated UVs. Shouldn't

in just point to the same UV index, instead of duplicating them?

Edit2: I created a ruby script to remove the redundancies: https://github.com/endavid/headerify/blob/master/bin/headerifyCollada.rb

$\endgroup$
  • $\begingroup$ Read about UVs being per-loop: blender.stackexchange.com/a/6710/1363 $\endgroup$ – CoDEmanX Feb 6 '14 at 23:15
  • $\begingroup$ Thanks :) The thing is that I have a simple model that uses spherical projection for the UV map, and I still get too many UVs. I created a script to get rid of the redundant vertices, and now I managed to reduce the number of {position, normal, uv} vertices from almost 400 to just 100 :) This is the script: github.com/endavid/headerify/blob/master/bin/… $\endgroup$ – endavid Feb 8 '14 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.