0
$\begingroup$

This is about the third time I have posted this question and unfortunately I have returned to ask it again. I am trying to create a scene here where the traffic Light has this Zinc coated texture to it. However, I have noticed that with some textures, (Mainly Transparent leaf Texture's and now this) that the image doesn't show up in the rendered view port. Now all of you have suggested that the pink image means the file or image is missing. But it isn't. When I go to the Material View port I can see it and also where the node's are. Please to help me find out why these textures are turning pink in the Rendered View port only.

enter image description here

$\endgroup$
  • $\begingroup$ Try, in de node editor, to browse to the image file again. The file may not be missing, but maybe the image has been moved $\endgroup$ – Faceb Faceb Nov 25 '16 at 13:02
  • $\begingroup$ I have tried that also Faceb Faceb. The image hasn't be moved from its original position. But thanks anyways mate. $\endgroup$ – Sarsha W Nov 25 '16 at 14:11
  • $\begingroup$ Also, is it correct that the pole is not entirely pink? It seems that the top of the pole has a dark area $\endgroup$ – Faceb Faceb Nov 25 '16 at 14:31
  • $\begingroup$ That is a separate Object. This happens a lot when I use transparent images for texturing but it is starting to affect normal images. So no everything that is pink is one object and was all Smart UV Unwrapped to the texture. $\endgroup$ – Sarsha W Nov 25 '16 at 14:37
  • $\begingroup$ Okay, and have you tried to assign new material and unwrap it again? $\endgroup$ – Faceb Faceb Nov 25 '16 at 14:44
2
$\begingroup$

@Sarsha W, I hope this doesn't come too late, I had the same problem yesterday, and i went through the same rectifications as in here. In my case all the objects were pink, and I could see the texture fine in texture mode. I found all the missing files. And in python I had no errors.

In my case, what solved the problem was to pack the images, save the "pink" file, and close it. Then I opened a brand new file, and appended the object from the "pink" file. After doing so, everything worked fine.

Other things you might want to test is to make sure the texture is not a corrupted image. And you can always test with a different texture that works in another .blend, that way if you still have it pink you know it's a different issue.

$\endgroup$
  • $\begingroup$ Yea, mate the only problem with mine was that it did it with every image, i did come up with a fix though. I just got a new computer and installed blender and now it works perfectly. But thanks anyways! $\endgroup$ – Sarsha W Jun 17 '17 at 12:20
1
$\begingroup$

I had the same problem, posted here.

Rick Riggs knows Blender. His suggestion to pack the image file:

Blender-> File -> External Data -> Automatically pack into .blend

worked like a charm.

For help packing images: Packing Texture Files In a Single Blend File

$\endgroup$
0
$\begingroup$

It seems that blender is missing the path to your texture.

Go to: File -> External Data -> Find Missing Files

And then search for the folder your texture is located. enter image description here

$\endgroup$
  • $\begingroup$ Sorry I have tried this as well, It is located by blender. It is just not showing in the Rendered View port. So sorry it still does not work. $\endgroup$ – Sarsha W Nov 25 '16 at 8:27
  • $\begingroup$ Does a full render solve the problem or is it just the viewport rendering? $\endgroup$ – Delagone Nov 25 '16 at 8:29
  • $\begingroup$ Its Both the Rendered View port and the final Render. $\endgroup$ – Sarsha W Nov 25 '16 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.