3
$\begingroup$

I'm having trouble getting blender's render result the same thing I see in object mode + render view

Here's render view: Here's render view

Here's render result Here's render result

I was following a tutorial tutorial but it didn't seem to encounter the same issue. perhaps I missed or toggled something. Things were going fine until I got to the "preview render" step towards the very end, when my render result showed what seemed to be the objects but with no material or lighting. Messed around a bit whit the UV mapping and world > surface and the result got a bit closer but still not what I expected. I was also having issues getting the camera & lamp to display, they are shown in the outline but in 3D view they are invisible.

project file:

https://drive.google.com/open?id=0B6jU39F0oQekVDQ2a2dDeVM0d2c

$\endgroup$
  • $\begingroup$ here is the project file: drive.google.com/open?id=0B6jU39F0oQekVDQ2a2dDeVM0d2c $\endgroup$ – dlo Nov 25 '16 at 1:24
  • $\begingroup$ Woah.... Don't know what you screwed up. But whatever you did, you screwed up verrry verryy much.... I can fix it... but I'm gonna have to reset your world settings. $\endgroup$ – 10 Replies Nov 25 '16 at 1:42
  • $\begingroup$ that's fine. the world settings I think are what changed everything from grey space > current state. It was still refusing to render materials prior to adjusting them, though. $\endgroup$ – dlo Nov 25 '16 at 2:05
  • $\begingroup$ I just opened your file in blender 2.78 and it looks just fine. The only odd thing I found is the local view mode. Just turned off pressing keypad / again and everything looked fine. $\endgroup$ – Gez Nov 25 '16 at 21:36
5
$\begingroup$

The issue is that the 'table' object isn't set to appear on any layer. You can see this by looking at the Relations panel for the 'table' object:

enter image description here

The rows of icons that represent the layers show that it isn't assigned to any layer in the scene and so it won't/can't appear in the final render.

I think this happens when you add a new object while in 'Local View'. If you are unaware, 'Local view' is a way of temporarily isolating any selected objects from the rest of the scene. This is done by selecting an object and pressing the Numpad /. 'Local' is then displayed as a label in the top left of the 3D viewport next to the view mode:

enter image description here

'Local View' can be exited by pressing the same key and it appears that it's only when exiting 'Local View' that new objects are assigned a layer.

To fix your file, either manually assign a layer to the object by pressing one of the layer buttons in the 'Relations' panel for the 'table' object (shown above) or exit 'Local View' (as your 3D view is already in Local View) with Numpad / to have the object automatically assigned a layer.


Bug Report

I did file a bug report about this issue here, but until the bug can be reproduced from scratch not much can be done.

$\endgroup$
  • $\begingroup$ @dlo With your permission I would like to submit your blend file to the blender bug tracker so the developers can take a look at why this might be happening. $\endgroup$ – Ray Mairlot Nov 25 '16 at 12:16
  • $\begingroup$ that is absolutely alright with me. Hopefully it helps :) $\endgroup$ – dlo Nov 26 '16 at 6:34
  • $\begingroup$ @dlo I did report it as a bug, which you can see in my updated question, but until the bug can be reproduced from scratch the developers can't really fix it. If you happen to come across this issue again and know what is causing it then either comment back here or post a comment on the bug report I have linked to. $\endgroup$ – Ray Mairlot Nov 30 '16 at 14:34
0
$\begingroup$

My Solution: In the World Settings disable Ambient Occlusion!

That button is very dangerous and seems like a bug because it is named in such a way where it seems like a world effect but it's not it's a preview mode and it disables the materials completely in order to show the AO view so beware.

To get real AO you gotta apply it in the materials.

$\endgroup$
-1
$\begingroup$

I went with the simple solution:

  • Create a new blender file

Create dat dope gif

  • Append your stuff

enter image description here

enter image description here

Don't forget to delete everything in the new blend file before you import your stuff


Also, you might want to watch some of Andrew Price's PBR (photo realistic) shaders tutorials or google something about fresnel.

$\endgroup$
  • $\begingroup$ Perhaps it was just a bug then. It was the first instance on a fresh install, and seems to only affect this project. Your method worked for the most part, there were some irregularities with appended materials but everything seems to be for the most part fine. Thanks for the trick of appending, should prove handy down the road. $\endgroup$ – dlo Nov 25 '16 at 3:07
  • 6
    $\begingroup$ This may be a solution but "whatever you did, try not to do it again" will never sit well with me as a good answer. $\endgroup$ – Ray Mairlot Nov 25 '16 at 10:13
  • 1
    $\begingroup$ The problem described is not a bug, and it has an easy solution. Importing the scene in a clean blender file may work, but it's not helpful to bring clarity about why the problem happened in the first place. $\endgroup$ – Gez Nov 25 '16 at 21:28
  • 2
    $\begingroup$ I understand that your intention was to help, and your answer clearly solves the problem. But I think this site is intended to be a knowledge base to help users understand how things work and why some things sometimes don't work. I think it's more productive to see this site as something else than just quick troubleshooting. $\endgroup$ – Gez Nov 25 '16 at 23:41
  • 3
    $\begingroup$ @10Replies The issue isn't your solution, it's the way it's passed off, I've answered many a questions with cheap alternatives, offer them as such as opposed to your opening line :). $\endgroup$ – iKlsR Nov 30 '16 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.