-1
$\begingroup$

Blend location: http://www.pasteall.org/blend/index.php?id=44414 Cetagon has posted related Stack Exchange questions. These are being reviewed and scanned for answers as well. Notice: ManuelLab 1.4.0 may be necessary, though all files were packed into this blend.

enter image description here

Pay attention to the eye textures and materials here. ManuelLab.

enter image description here

...Something wrong?

The fix for stills is to cut a hole through the glass. At this point, I am just looking for an electronic miracle, but is there any fix for this, beyond faking the existence of glass with transparent reflective textures? The material is glass for the window, and the eyes have materials set with textures.

Render Engine: Cycles. Settings: Awaiting clarification Materials and textures: Explaining through Node setup...

enter image description here

Of particular relevance: the glass and transparent material out of Archimesh. Just the Glass, alone, achieves this result.

Intended result: eyes visible through glass. (attempted fix)

$\endgroup$
  • 1
    $\begingroup$ Please edit your question and clarify what you are trying to achieve. It's not clear what you are asking, what render engine you are using, what settings and materials you have, and what node setups you are using. $\endgroup$ – Duarte Farrajota Ramos Nov 23 '16 at 3:36
  • $\begingroup$ I could explain what settings I have, but I am not sure what you mean. Everything else, I could explain, though. $\endgroup$ – Darknaviexe Nov 23 '16 at 3:48
  • $\begingroup$ By settings I mean everything else, lie render settings, object specific settings, object geometry (maybe a wireframe view?) You screenshot is too small, it's hard to make out the text. Maybe post your Blend file if you can $\endgroup$ – Duarte Farrajota Ramos Nov 23 '16 at 4:11
  • 4
  • $\begingroup$ Blend location posted at top of question. $\endgroup$ – Darknaviexe Nov 23 '16 at 23:40
0
$\begingroup$

This sounds sudden at this point, but I have found an answer. This answer will be especially strange and a crude workaround at best, but this is an answer, nonetheless.

enter image description here

The node setup is blurry, as I had noticed, not what happened during the screenshot, though. I will explain.

You can see a tall node on the left side of the setup. That is a Light Path Node. Disconnecting this node solves the problem, or at least, gets the results I want: A reflection in the glass and eyes visible on the other side. I had previously tried using other starting connections. "Is Camera Ray" came close, but no reflections. The rest still removed the eyes.

$\endgroup$
  • 1
    $\begingroup$ upload images with a higher resolution. It is very hard to read what you are doing. $\endgroup$ – cegaton Nov 24 '16 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.