3
$\begingroup$

Trying to animate an object's material, by simply changing its opacity.

As there is no way to directly change the material properties in the AN node tree, I created a driver to change the value of Transparency's "Alpha".

So, the execution flow goes like:

  1. "Object Attribute Output" creates/change a property named "alpha" within the object;
  2. this property is used by the driver to...
  3. set that object's material transparency.

In theory this should work, but:

  • it works with text objects;
  • it does not work with any other type of object.

Am I doing something wrong? Or is this supposed to be that way?

Example screenshot

$\endgroup$
2
$\begingroup$

No sure why the driver does not update in the cube but does on the text object. This does not seem to be an Animation Nodes bug. It's more likely a dependency graph problem of Blender.

What you can do is to control the transparency of the material directly by using active_material.alpha as path in the Object Attribute Output node.

$\endgroup$
  • $\begingroup$ Maybe you should activate the new desgraph in order to see if this behaviour persists $\endgroup$ – Jorge Losilla Martínez Nov 23 '16 at 8:00
  • $\begingroup$ Nice! active_material.alpha does the trick - and without a driver! Thanks! But I think I'll leave the question open till solved the mystery of the driver? $\endgroup$ – Ricardo Roehe Nov 23 '16 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.