3
$\begingroup$

I made a huge project, wanted to reduce file size from 1.3GB to below 1GB. Compressing did not help. I removed objects from scene. Also textures. I then realized, the file size even was the same when I delete all objects. Why?

Download of sample: https://ufile.io/0cc23

Before deleting all: 1.2GB, after: 1.1GB. File size does not shrink

$\endgroup$
4
  • $\begingroup$ Are you sure you actually removed the object data? Do they show as having zero users before closing? Don't they have fake users set up? They may be in use elsewhere in another scene or object. $\endgroup$ Commented Nov 20, 2016 at 15:06
  • $\begingroup$ I uploaded a sample. I don't know if all is removed. It seems not. But in the outliner there is nothing to find. No objects in outliner. All deleted. Still over 200MB. $\endgroup$
    – Nasenbaer
    Commented Nov 20, 2016 at 15:11
  • $\begingroup$ Interesting. Did you try File/External Data/Unpack All Into Files? $\endgroup$
    – lbalazscs
    Commented Nov 20, 2016 at 17:48
  • $\begingroup$ Yes. File > External Data > unpack all. No success. That is the file I've uploaded as sample. $\endgroup$
    – Nasenbaer
    Commented Nov 20, 2016 at 23:07

2 Answers 2

12
$\begingroup$

If your file has a large size and your scenes are apparently empty it means there are other datablocks saved in your file but not in current use in your scenes, or at least your current scene.

Try switching your Outliner to Group view and you will find plenty of group definitions you can insert into your scene, with lots of high poly objects stored in them.

Groups

Otherwise if this is not the case, go into the Outliner and change the view context to Datablocks; for Blender 2.8+ versions you can use both or Blender File or Data API display modes. There you can see a list of categories containing different data-types stored inside your file, like images, objects, groups, brushes, etc. This should give a hint at what is taking the most space inside your blend file.

enter image description here

After that you can also have a look at orphaned data. To see this in the Outliner change display mode to Orphan Data and see what data is unused but still saved inside your file. If any is undesirable you can purge it all using the Purge button up top right, or individually by right clicking the item and choosing Delete or Unlink.

enter image description here

To actually delete data, select the (un)desired groups in the Outliner under Group mode, Right Click over the group name (not the icon) and choose Unlink option.

Pre Blender 2.8, you have to save the file, quit Blender and then reopen the file again, for actual data to be gone. Save again and file size should be reduced.

For 2.8+ you can check again the Orphan Data in the Outliner and repeat the steps described above.

For you particular case, only way I figured out how to actually reduce file was to go into the Outliner, after unlinking all groups as described above, switch to Blender File mode, go into the Mesh category and manually select everything and erase it with Right Click > Delete. This reduced file size to about 5Mb

Due to the large amount it is probably easier to just select everything with A and deselect all other categories before erasing

$\endgroup$
7
  • $\begingroup$ With your animated images (how did you do that?) I fully understand. I was on "all objects" and I still do not understand why blender does not present it that way. Great to see the "Groups" solution. Thank you $\endgroup$
    – Nasenbaer
    Commented Nov 21, 2016 at 6:48
  • $\begingroup$ I am still unable to reduce file size to nearly zero. I can see the items but not delete them. $\endgroup$
    – Nasenbaer
    Commented Nov 21, 2016 at 7:10
  • $\begingroup$ I forgot to add that, to actually get rid of it you have to unlink the groups from the outliner, answer updated above. $\endgroup$ Commented Nov 21, 2016 at 7:22
  • $\begingroup$ GIFs are captured with ScreentoGif $\endgroup$ Commented Nov 21, 2016 at 7:25
  • $\begingroup$ I added an animation. Problem still not solved. $\endgroup$
    – Nasenbaer
    Commented Nov 21, 2016 at 9:02
2
$\begingroup$

Try deleting lighting cache. In 2.8, click on little camera icon, find "Indirect Lighting" section, in there you can click on "Delete Lighting Cache".

If you hover over "Delete Lighting Cache" it will tell you how much space the cache is using.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .