2
$\begingroup$

I made a huge project, wanted to reduce file size from 1.3GB to below 1GB. Compressing did not help. I removed objects from scene. Also textures. I then realized, the file size even was the same when I delete ALL objects. Why?

Download of sample: https://ufile.io/0cc23

Before deleting all: 1.2GB, after: 1.1GB. File size does not shrink

$\endgroup$
  • $\begingroup$ Are you sure you actually removed the object data? Do they show as having zero users before closing? Don't they have fake users set up? They may be in use elsewhere in another scene or object. $\endgroup$ – Duarte Farrajota Ramos Nov 20 '16 at 15:06
  • $\begingroup$ I uploaded a sample. I don't know if all is removed. It seems not. But in the outliner there is nothing to find. No objects in outliner. All deleted. Still over 200MB. $\endgroup$ – Nasenbaer Nov 20 '16 at 15:11
  • $\begingroup$ Interesting. Did you try File/External Data/Unpack All Into Files? $\endgroup$ – lbalazscs Nov 20 '16 at 17:48
  • $\begingroup$ Yes. File > External Data > unpack all. No success. That is the file I've uploaded as sample. $\endgroup$ – Nasenbaer Nov 20 '16 at 23:07
7
$\begingroup$

Your scene is far from empty (couldn't be any other way), there are plenty of objects there stored inside groups.

Try switching your outliner to Group view and you will find plenty of group definitions you can insert into your scene, with lots of high poly objects stored in them.

Groups

Not sure exactly how they are stored or where they come from, but they are causing your big file size. Will try to investigate further.

If you go into the Outliner > Datablocks view you can also see lots of data stored inside your file, like images, objects, groups, brushes, etc.

enter image description here

To actually delete data, select the (un)desired groups in the Outliner under Group mode, Right Click over the group name (not the icon) and choose Unlink option.

You have to save, quit file, close Blender and then reopen the file again, for actual data to be gone. Save again and file size should be reduced.

EDIT

Ok, only way I figured out how to actually reduce file was to go into the Outliner, after unlinking all groups as described above, switch to Blender File mode, go into the Mesh category and manually select everything and erase it with Right Click > Delete. This reduced file size to about 5Mb

Due to the large amount it is probably easier to just select everything with A and deselect all other categories before erasing

$\endgroup$
  • $\begingroup$ With your animated images (how did you do that?) I fully understand. I was on "all objects" and I still do not understand why blender does not present it that way. Great to see the "Groups" solution. Thank you $\endgroup$ – Nasenbaer Nov 21 '16 at 6:48
  • $\begingroup$ I am still unable to reduce file size to nearly zero. I can see the items but not delete them. $\endgroup$ – Nasenbaer Nov 21 '16 at 7:10
  • $\begingroup$ I forgot to add that, to actually get rid of it you have to unlink the groups from the outliner, answer updated above. $\endgroup$ – Duarte Farrajota Ramos Nov 21 '16 at 7:22
  • $\begingroup$ GIFs are captured with ScreentoGif $\endgroup$ – Duarte Farrajota Ramos Nov 21 '16 at 7:25
  • $\begingroup$ I added an animation. Problem still not solved. $\endgroup$ – Nasenbaer Nov 21 '16 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.